前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3694 Network(Tarjan求割边+LCA)

POJ 3694 Network(Tarjan求割边+LCA)

作者头像
attack
发布2018-04-10 17:09:26
7160
发布2018-04-10 17:09:26
举报

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000). Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network. The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one. The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B. The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

代码语言:javascript
复制
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

代码语言:javascript
复制
Case 1:
1
0

Case 2:
2
0

Source

题目大意:

给出一张图,询问每次加边之后图中有多少割边

首先我们来一遍tarjan

这样实际上形成了一棵树

对于每次询问,我们找出它们的LCA

在往LCA走的过程中判断是否是割边,如果是就取消标记

LCA暴力就可以,父亲节点的信息可以在tarjan的过程中得到

代码语言:javascript
复制
// luogu-judger-enable-o2
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<stack>
//#define getchar() (S == T && (T = (S = BB) + fread(BB, 1, 1 << 15, stdin), S == T) ? EOF : *S++)
//char BB[1 << 15], *S = BB, *T = BB;
using namespace std;
const int MAXN=1e6+10;
inline int read()
{
    char c=getchar();int x=0,f=1;
    while(c<'0'||c>'9'){if(c=='-')f=-1;c=getchar();}
    while(c>='0'&&c<='9'){x=x*10+c-'0';c=getchar();}
    return x*f;
}
struct node
{
    int u,v,nxt;
}edge[MAXN];
int head[MAXN],num=1;
inline void AddEdge(int x,int y)
{
    edge[num].u=x;
    edge[num].v=y;
    edge[num].nxt=head[x];
    head[x]=num++;
}
int N,M;

int dfn[MAXN],low[MAXN],f[MAXN],deep[MAXN],tot=0;
int bridge[MAXN],ans=0;
void pre()
{
    for(int i=1;i<=N;i++) f[i]=i;
    memset(head,-1,sizeof(head));
    num=1;
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    memset(bridge,0,sizeof(bridge));
    tot=0;
    ans=0;
}
void tarjan(int now,int fa)
{
    dfn[now]=low[now]=++tot;
    for(int i=head[now];i!=-1;i=edge[i].nxt)
    {
        if(!dfn[edge[i].v]) 
        {
            deep[edge[i].v]=deep[now]+1;
            f[edge[i].v]=now;
            tarjan(edge[i].v,now);
            low[now]=min(low[now],low[edge[i].v]);
            if(low[edge[i].v]>dfn[now])
            {
                bridge[edge[i].v]=1;
                ans++;
            }
        }    
        else if(edge[i].v!=fa) low[now]=min(low[now],dfn[edge[i].v]); 
    }
}
int Solve(int x,int y)
{
    if(deep[x]<deep[y]) swap(x,y);
    while(deep[x]!=deep[y])
    {
        if(bridge[x]) ans--,bridge[x]=0;
        x=f[x];    
    } 
    while(x!=y)
    {
        if(bridge[x]) ans--,bridge[x]=0;
        if(bridge[y]) ans--,bridge[y]=0;
        x=f[x];y=f[y];
    }
    return ans;
}
int main()
{
    #ifdef WIN32
    freopen("a.in","r",stdin);
    #else
    #endif
    int QWQ=0;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        if(N==0&&M==0) break;
        printf("Case %d:\n",++QWQ);
        pre();
        for(int i=1;i<=M;i++)
        {
            int x=read(),y=read();
            AddEdge(x,y);
            AddEdge(y,x);
        }
        deep[1]=1;
        tarjan(1,0);
        int Q=read();
        while(Q--)
        {
            int x=read(),y=read();
            printf("%d\n",Solve(x,y));
        }
        putchar('\n');
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2018-02-27 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Input
  • Output
  • Sample Input
  • Sample Output
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档