前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-1322 Chocolate(概率DP)

POJ-1322 Chocolate(概率DP)

作者头像
ShenduCC
发布2018-04-25 17:24:05
5920
发布2018-04-25 17:24:05
举报
文章被收录于专栏:算法修养算法修养

Chocolate Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 9279 Accepted: 2417 Special Judge Description

In 2100, ACM chocolate will be one of the favorite foods in the world.

“Green, orange, brown, red…”, colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it’s said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits.

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table.

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what’s the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out? Input

The input file for this problem contains several test cases, one per line.

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000).

The input is terminated by a line containing a single zero. Output

The output should be one real number per line, shows the probability for each case, round to three decimal places. Sample Input

5 100 2

0 Sample Output

0.625 题意:就是在一堆巧克力中选取n个,每当有两个颜色一样的巧克力就把他们吃了,问,桌面上剩下的巧克力是m个的概率。这是一道概率DP题目。状态转移方程: dp[i][j]=dp[i-1][j-1](c-(j-1))/(c*1.0)+dp[i-1][j+1](j+1)/(c*1.0); 此题注意,数据量相当大,有两个节省大量时间的减值,一个是若m和n同奇或同偶的,则概率为0 n大于1000的时候, if(n>1000) { n=1000+n%2; } 似乎用到统计学的知识,反正大于1000,之后的数据量影响不大,相当于1000或者1001;

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
double dp[1010][105];
int c,n,m;
int main()
{
    while(scanf("%d",&c)!=EOF)
    {   if(c==0)
            break;
        scanf("%d%d",&n,&m);
        if(m>c||m>n||((n%2)!=(m%2)))
        {
            printf("0.000\n");
        }
        else
        {
            if(n>1000)
            {
                n=1000+n%2;
            }
            memset(dp,0,sizeof(dp));
            dp[0][0]=1;
            dp[1][0]=0;
            for(int i=1;i<=n;i++)
            {
                dp[i][0]=dp[i-1][1]*(1)/(c*1.0);
                dp[i][c]=dp[i-1][c-1]*(c-(c-1))/(c*1.0);
                for(int j=1;j<c;j++)
                {
                    dp[i][j]=dp[i-1][j-1]*(c-(j-1))/(c*1.0)+dp[i-1][j+1]*(j+1)/(c*1.0);

                }
            }
            printf("%.3lf\n",dp[n][m]);

        }
    }
    return 0;
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2015-12-20 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档