前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >FZU Moon Game(几何)

FZU Moon Game(几何)

作者头像
ShenduCC
发布2018-04-26 16:11:28
6110
发布2018-04-26 16:11:28
举报
文章被收录于专栏:算法修养算法修养

Accept: 710    Submit: 2038 Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Fat brother and Maze are playing a kind of special (hentai) game in the clearly blue sky which we can just consider as a kind of two-dimensional plane. Then Fat brother starts to draw N starts in the sky which we can just consider each as a point. After he draws these stars, he starts to sing the famous song “The Moon Represents My Heart” to Maze.

You ask me how deeply I love you,

How much I love you?

My heart is true,

My love is true,

The moon represents my heart.

But as Fat brother is a little bit stay-adorable(呆萌), he just consider that the moon is a special kind of convex quadrilateral and starts to count the number of different convex quadrilateral in the sky. As this number is quiet large, he asks for your help.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains an integer N describe the number of the points.

Then N lines follow, Each line contains two integers describe the coordinate of the point, you can assume that no two points lie in a same coordinate and no three points lie in a same line. The coordinate of the point is in the range[-10086,10086].

1 <= T <=100, 1 <= N <= 30

 Output

For each case, output the case number first, and then output the number of different convex quadrilateral in the sky. Two convex quadrilaterals are considered different if they lie in the different position in the sky.

 Sample Input

240 0100 00 100100 10040 0100 00 10010 10

 Sample Output

Case 1: 1Case 2: 0

我直接用了凸包算法,大材小用了

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <math.h>
#include <stdio.h>
#include <stdlib.h>
#include <algorithm>

using namespace std;
struct Node
{
    int x;
    int y;
}a[5],b[35];
int s[10];
int top;
int cross(Node a,Node b,Node c)
{
    return (b.x-a.x)*(c.y-a.y)-(b.y-a.y)*(c.x-a.x);
}
int dis(Node a,Node b)
{
    return sqrt((double)(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
int cmp(Node p1,Node p2)
{
    int temp=cross(a[0],p1,p2);
    if(temp>0) return true;
    else if(temp==0&&dis(a[0],p1)<dis(a[0],p2)) return true;
    else return false;
}
int cmp2(Node a,Node b)
{
    if(a.y==b.y)
        return a.x<b.x;
    return a.y<b.y;
}
int graham(int n)
{
    if(n==1){return 0;}
    if(n==2){return 1;}
    if(n>2)
    {
        top=1;s[0]=0;s[1]=1;
        for(int i=2;i<n;i++)
        {
            while(top>0&&cross(a[s[top-1]],a[s[top]],a[i])<=0)
                top--;
            s[++top]=i;
        }

        return top;

    }

}
int n;
int main()
{
    int t;
    scanf("%d",&t);
    int cas=0;
    int ans=0;
    while(t--)
    {
       scanf("%d",&n);
       ans=0;
       for(int i=1;i<=n;i++)
            scanf("%d%d",&b[i].x,&b[i].y);
       for(int i=1;i<=n;i++)
       {

        for(int j=i+1;j<=n;j++)
        {

          for(int k=j+1;k<=n;k++)
          {

            for(int p=k+1;p<=n;p++)
            {
                a[0]=b[i];a[1]=b[j];a[2]=b[k];a[3]=b[p];
                sort(a,a+4,cmp2);

                sort(a+1,a+4,cmp);

                //cout<<i<<" "<<j<<" "<<k<<" "<<p<<endl;
                if(graham(4)==3)
                {
                   // cout<<i<<" "<<j<<" "<<k<<" "<<p<<endl;
                    ans++;
                }
            }
          }
        }
       }
       printf("Case %d: %d\n",++cas,ans);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-04-16 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Accept: 710    Submit: 2038 Time Limit: 1000 mSec    Memory Limit : 32768 KB
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档