前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 2059 The Twin Towers(双塔DP)

ZOJ 2059 The Twin Towers(双塔DP)

作者头像
ShenduCC
发布2018-04-26 17:23:51
4420
发布2018-04-26 17:23:51
举报
文章被收录于专栏:算法修养算法修养

The Twin Towers


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Twin towers we see you standing tall, though a building's lost our faith will never fall.

Twin towers the world hears your call, though you're gone it only strengthens our resolve.

We couldn't make it through this without you Lord, through hard times we come together more. ... 

Twin Towers - A Song for America

In memory of the tragic events that unfolded on the morning of September 11, 2001, five-year-old Rosie decids to rebuild a tallest Twin Towers by using the crystals her brother has collected for years. Will she succeed in building the two towers of the same height?

Input

There are mutiple test cases.

One line forms a test case. The first integer N (N < 100) tells you the number of crystals her brother has collected. Then each of the next N integers describs the height of a certain crystal.

A negtive N indicats the end.

Note that all crytals are in cube shape. And the total height of crystals is smaller than 2000.

Output If it is impossible, you would say "Sorry", otherwise tell her the height of the Twin Towers.

Sample Input 4 11 11 11 11 4 1 11 111 1111  -1

Sample Output 22 Sorry

双塔DP

dp[i][2000] 表示第i个砖块,堆成两个塔的高度差,每个砖块有两个选择要么不用,要么放左边的塔,要么放右边的塔

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int a[105];
int dp[105][4005];
int n;
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        if(n<0)
            break;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(dp,-1,sizeof(dp));
        dp[0][0+2000]=0;
        for(int i=1;i<=n;i++)
        {
            memcpy(dp[i],dp[i-1],sizeof(dp[i]));
            for(int j=-1999;j<=1999;j++)
            {
                if(dp[i-1][j+2000]==-1) continue;
                if(j<0)
                {
                    dp[i][j-a[i]+2000]=max(dp[i][j-a[i]+2000],dp[i-1][j+2000]+a[i]);
                    dp[i][j+a[i]+2000]=max( dp[i][j+a[i]+2000],dp[i-1][j+2000]+max(0,j+a[i]));
                }
                else
                {
                    dp[i][j+a[i]+2000]=max( dp[i][j+a[i]+2000],dp[i-1][j+2000]+a[i]);
                    dp[i][j-a[i]+2000]=max(dp[i][j-a[i]+2000],dp[i-1][j+2000]+max(0,a[i]-j));
                }

            }
        }
        if(dp[n][2000]!=0&&dp[n][2000]!=-1)
            printf("%d\n",dp[n][2000]);
        else
            printf("Sorry\n");
    }
    return 0;
}

The Twin Towers


Time Limit: 2 Seconds      Memory Limit: 65536 KB


Twin towers we see you standing tall, though a building's lost our faith will never fall. Twin towers the world hears your call, though you're gone it only strengthens our resolve. We couldn't make it through this without you Lord, through hard times we come together more. ...  Twin Towers - A Song for America In memory of the tragic events that unfolded on the morning of September 11, 2001, five-year-old Rosie decids to rebuild a tallest Twin Towers by using the crystals her brother has collected for years. Will she succeed in building the two towers of the same height? Input There are mutiple test cases.

One line forms a test case. The first integer N (N < 100) tells you the number of crystals her brother has collected. Then each of the next N integers describs the height of a certain crystal.

A negtive N indicats the end.

Note that all crytals are in cube shape. And the total height of crystals is smaller than 2000.

Output If it is impossible, you would say "Sorry", otherwise tell her the height of the Twin Towers.

Sample Input 4 11 11 11 11 4 1 11 111 1111  -1

Sample Output 22 Sorry

本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档