前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ 3661 Palindromic Substring(回文树)

ZOJ 3661 Palindromic Substring(回文树)

作者头像
ShenduCC
发布2018-04-26 17:29:12
4510
发布2018-04-26 17:29:12
举报
文章被收录于专栏:算法修养算法修养

Palindromic Substring


Time Limit: 10 Seconds      Memory Limit: 65536 KB


In the kingdom of string, people like palindromic strings very much. They like only palindromic strings and dislike all other strings. There is a unified formula to calculate the score of a palindromic string. The score is calculated by applying the following three steps.

  1. Since a palindromic string is symmetric, the second half(excluding the middle of the string if the length is odd) is got rid of, and only the rest is considered. For example, "abba" becomes "ab", "aba" becomes "ab" and "abacaba" becomes "abac".
  2. Define some integer values for 'a' to 'z'.
  3. Treat the rest part as a 26-based number M and the score is M modulo 777,777,777.

However different person may have different values for 'a' to 'z'. For example, if 'a' is defined as 3, 'b' is defined as 1 and c is defined as 4, then the string "accbcca" has the score (3×263+4×262+4×26+1) modulo 777777777=55537.

One day, a very long string S is discovered and everyone in the kingdom wants to know that among all the palindromic substrings of S, what the one with the K-th smallest score is.

Input

The first line contains an integer T(1 ≤ T ≤ 20), the number of test cases.

The first line in each case contains two integers n, m(1 ≤ n ≤ 100000, 1 ≤ m ≤ 20) where n is the length of S and m is the number of people in the kingdom. The second line is the string S consisting of only lowercase letters. The next m lines each containing 27 integers describes a person in the following format.

Ki va vb ... vz

where va is the value of 'a' for the person, vb is the value of 'b' and so on. It is ensured that the Ki-th smallest palindromic substring exists and va, vb, ..., vz are in the range of [0, 26). But the values may coincide.

Output

For each person, output the score of the K-th smallest palindromic substring in one line. Print a blank line after each case.

Sample Input
代码语言:javascript
复制
3
6 2
abcdca
3 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
7 25 24 23 22 21 20 19 18 17 16 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0
4 10
zzzz
1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
3 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
4 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
5 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
6 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
7 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
8 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
9 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
10 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 14
51 4
abcdefghijklmnopqrstuvwxyzyxwvutsrqponmlkjihgfedcba
1 1 3 3 25 20 25 21 7 0 9 7 3 16 15 14 19 5 19 19 19 22 8 23 2 4 1
25 1 3 3 25 20 25 21 7 0 9 7 3 16 15 14 19 5 19 19 19 22 8 23 2 4 1
26 1 3 3 25 20 25 21 7 0 9 7 3 16 15 14 19 5 19 19 19 22 8 23 2 4 1
76 1 3 3 25 20 25 21 7 0 9 7 3 16 15 14 19 5 19 19 19 22 8 23 2 4 1
Sample Output
代码语言:javascript
复制
1
620

14
14
14
14
14
14
14
378
378
378

0
9
14
733665286
回文树#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>

using namespace std;
typedef long long int LL;
const int maxn=1e5+5;
const int mod=777777777;
char str[maxn];
int n,m;
LL k;
int a[26];
LL pow(int x)
{
	LL sum=1;
	LL n=26;
	for(x;x;x>>=1)
	{
		if(x&1)
			sum=(sum*n)%mod;
		n=(n*n)%mod;
	}
	return sum;
}
struct Node
{
	LL num;
	LL sum;
}c[maxn];
int cmp(Node a,Node b)
{
	return a.sum<b.sum;
}
struct Tree
{
	int next[maxn][26];
	int fail[maxn];
	LL num[maxn];
	int cnt[maxn];
	int len[maxn];
	int s[maxn];
	int last,p,n;
	int new_node(int x)
	{
		memset(next[p],0,sizeof(next[p]));
		cnt[p]=0;
		num[p]=0;
		len[p]=x;
		return p++;
	}
	void init()
	{
		p=0;
		new_node(0);
		new_node(-1);
		last=0;
		n=0;
		s[0]=-1;
		fail[0]=1;
	}
	int get_fail(int x)
	{
		while(s[n-len[x]-1]!=s[n])
			x=fail[x];
		return x;
	}
	int add(int x)
	{
		x-='a';
		s[++n]=x;
		int cur=get_fail(last);
		if(!(last=next[cur][x]))
		{
			int now=new_node(len[cur]+2);
			fail[now]=next[get_fail(fail[cur])][x];
			next[cur][x]=now;
			num[now]=(num[cur]+((LL)pow((len[cur]+1)/2)*a[x])%mod)%mod;
			last=now;
		}
		cnt[last]++;
		return 1;
	}
	void count()
	{
		for(int i=p-1;i>=0;i--)
			cnt[fail[i]]+=cnt[i];
	}
	void fun()
	{
		count();
		int cot=0;
		for(int i=2;i<p;i++)
		{
			c[cot].num=cnt[i];
			c[cot++].sum=num[i];
		}
		sort(c,c+cot,cmp);
		int i;
		for( i=0;i<cot;i++)
		{
			if(k>c[i].num)
			{
				k-=c[i].num;
			}
			else
				break;
		}
        printf("%d\n",c[i].sum);
	}
}tree;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
        scanf("%d%d",&n,&m);
		scanf("%s",str);
		for(int i=1;i<=m;i++)
		{
			scanf("%lld",&k);
			for(int j=0;j<26;j++)
				scanf("%d",&a[j]);
			tree.init();
			for(int j=0;j<n;j++)
			{
                 tree.add(str[j]);
			}
			tree.fun();
        }
		cout<<endl;
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-10 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Input
  • Output
  • Sample Input
  • Sample Output
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档