前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 甲级 1019 General Palindromic Number(简单题)

PAT 甲级 1019 General Palindromic Number(简单题)

作者头像
ShenduCC
发布2018-04-27 10:32:52
9750
发布2018-04-27 10:32:52
举报
文章被收录于专栏:算法修养

1019. General Palindromic Number (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:

代码语言:javascript
复制
27 2

Sample Output 1:

代码语言:javascript
复制
Yes
1 1 0 1 1

Sample Input 2:

代码语言:javascript
复制
121 5

Sample Output 2:

代码语言:javascript
复制
No
4 4 1
代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>

using namespace std;
int n,b;
int a[10005];
int cnt;
void dfs(int n,int b)
{
  if(n<b)
  {
    a[cnt++]=n;
    return;
  }
  dfs(n/b,b);
  a[cnt++]=n%b;
}
int main()
{
  while(scanf("%d%d",&n,&b)!=EOF)
  {
    cnt=0;
    dfs(n,b);
    int i=0,j=cnt-1;
    int ans=0;
    while(i<=j)
    {
           if(a[i]!=a[j])
       {
         ans=-1;
         break;
       }
       i++,j--;
    }
    if(ans==-1)
      printf("No\n");
    else
      printf("Yes\n");
    for(int i=0;i<cnt;i++)
    {
      if(i==cnt-1)
        printf("%d\n",a[i]);
      else
          printf("%d ",a[i]);
    }
    
  }
  return 0;

}

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-05-30 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1019. General Palindromic Number (20)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档