前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 甲级 1060 Are They Equal

PAT 甲级 1060 Are They Equal

作者头像
ShenduCC
发布2018-04-27 10:50:12
7570
发布2018-04-27 10:50:12
举报
文章被收录于专栏:算法修养算法修养

1060. Are They Equal (25)

时间限制

50 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

代码语言:javascript
复制
3 12300 12358.9

Sample Output 1:

代码语言:javascript
复制
YES 0.123*10^5

Sample Input 2:

代码语言:javascript
复制
3 120 128

Sample Output 2:

代码语言:javascript
复制
NO 0.120*10^3 0.128*10^3

这道题目写的真窝火,所以刚AC,就跑来写博客,好鄙视一下题目。

题目的给定数字会有这样的情况

00234.34000

要把他转换成234.34

另外0.0001科学技术法应该是0.1*10^-3,而不是0.0001*10^0

当n大于数字的个数的时候,要补零

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <math.h>
#include <string>


using namespace std;
pair<string,int> m;
string a,b;
string aa,bb;
int n;
pair<string,int> fun(string a)
{
    int len=a.length();
    int begin,end;
    int tag1=0,tag2=0;
    for(int i=0;i<len;i++)//去除前缀的0和后缀的0
    {
        if(!tag1&&(a[i]!='0'||(a[i]=='0'&&a[i+1]=='.')))
            begin=i,tag1=1;
        if(tag2==1&&a[i]!='0')
                end=i;
        if(tag2==0)
            end=i;
        if(a[i]=='.')
            tag2=1;
    }
    string c=a.substr(begin,end-begin+1);
    int i;
    for(i=0;c[i];i++)//找到小数点的位置

        if(c[i]=='.')
            break;
    int j;
    for(j=0;c[j];j++)//找到第一个不是0的数字位置,即科学技术法中小数点应该放在哪个位置之前,
    {
        if(c[j]!='0'&&c[j]!='.')
            break;
    }
    string d="0.";int num=0;
    for(int ii=j;c[ii];ii++)
    {
        if(c[ii]=='.') continue;
        d+=c[ii];
        num++;
        if(num>=n)
            break;
    }
    for(int i=0;i<n-num;i++)//补0
        d+='0';
        
    int k=i-j;//小数点位置的变化,就是指数
    if(k<0) k++;
    m.first=d;
    m.second=k;
    return m;
}
int main()
{
    cin>>n>>a>>b;
    pair<string,int> mm1,mm2;
    mm1=fun(a);
    mm2=fun(b);
    if(mm1==mm2)
        cout<<"YES "<<mm1.first<<"*10^"<<mm1.second<<endl;
    else
        cout<<"NO "<<mm1.first<<"*10^"<<mm1.second<<" "<<mm2.first<<"*10^"<<mm2.second<<endl;
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-07-12 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1060. Are They Equal (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档