在 MAC OS X 安装 ADB (Android调试桥)

什么是 ADB?

Android调试桥( adb )是一个开发工具,帮助安卓设备和个人计算机之间的通信。 这种通信大多是在USB电缆下进行,但是也支持Wi-Fi连接。 adb 还可被用来与电脑上运行的安卓模拟器交流通信。 adb 对于安卓开发来说就像一把“瑞士军刀”。

通过 Homebrew 安装

brew cask install android-platform-tools

测试是否正常安装

adb devices

手动安装

1、如果你以前安装过,请先删除老的文件

rm -rf ~/.android-sdk-macosx/

2、下载 android-sdk-macosx

下载地址:developer.android.com

3、将下载的文件解压并移动到 ~/.android-sdk-macosx

cd ~/Downloads(你的下载目录)/
unzip android-sdk*.zip
mv android-sdk-macosx/ ~/.android-sdk-macosx

4、运行 SDK Manager

sh ~/.android-sdk-macosx/tools/android

5、根据你的需要选择,(我只需要Android SDK Platform-tools)[可选步骤] 6、选好后 Install 7、环境变量设置

  echo 'export PATH=$PATH:~/.android-sdk-macosx/platform-tools/' >> ~/.bash_profile

8、更新配置文件

source ~/.bash_profile

9、测试是否正常安装

adb devices
作者:Lee_dev
链接:https://www.jianshu.com/p/1b3fb1f27b67
來源:简书
著作权归作者所有。商业转载请联系作者获得授权,非商业转载请注明出处。

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

发表于

我来说两句

0 条评论
登录 后参与评论

相关文章

来自专栏网商云

小白教程--centos7修改ssh远程端口

关联链接:http://partners.qcloud.com/invitation/316656189255ac6a2b86868

2474
来自专栏搜云库

ZooKeeper 可视化监控 zkui

概述 一、简介zkui它提供了一个管理界面,可以针对zookeepr的节点值进行CRUD操作,同时也提供了安全认证。 二、下载安装 1、下载地址 https:...

2615
来自专栏GAN&CV

Ubuntu16.04安装opencv2&&ImportError: No module named cv2.cv

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_25737169/article/d...

1413
来自专栏信安之路

Windows环境下的信息收集

通常我们在渗透测试过程中,遇到的Windows的环境是最多的,然而在拿到一台windows系统权限之后,我们要进行横向或者纵向渗透,这是针对windows的信息...

670
来自专栏Python中文社区

Python开源项目介绍:用zmail简单地发邮件

发送邮件是个很简单的需求,但是在实际的使用中依然碰到了很多坑,因此创建了zmail这个项目,让你使用python发送邮件的过程尽可能简单。

983
来自专栏无题

分布式Session一致性解决方案

在分布式架构或微服务架构下,必须保证一个应用服务器上保存Session后,其它应用服务器可以同步或共享这个Session Web应用在单机部署的情况下,Ses...

3336
来自专栏建站达人秀

如何部署 Tomcat 站点

Tomcat 是 Apache 软件基金会(Apache Software Foundation)的Jakarta 项目中的一个核心项目,由 Apache、Su...

1010
来自专栏何俊林

Ubuntu18.04 从头开始编译 Android Native WebRTC

本文详细记录Mac下使用PD虚拟机安装ubuntu18.4桌面版,编译Android Native WebRTC的过程。

832
来自专栏漏斗社区

工具| OpenVas基础安装及使用篇

OpenVAS是开放式漏洞评估系统,也称为一个包含着相关工具的网络扫描器。其核心部件是一个服务器,包括一套网络漏洞测试程序,可以检测远程系统和应用程序中的安全问...

3678
来自专栏桥路_大数据

Gradle打包问题Deprecated Gradle features were used in this build, making it incompatible with Gradle 5.0

8124

扫码关注云+社区