前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ-3641:Pseudoprime numbers(快速幂)

POJ-3641:Pseudoprime numbers(快速幂)

作者头像
ACM算法日常
发布2018-08-07 18:23:31
3600
发布2018-08-07 18:23:31
举报
文章被收录于专栏:ACM算法日常ACM算法日常

题目:

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-a pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no no yes no yes yes

概译:费马定理觉得所有的素数p都是,给定一个大于1小于p的a, a的p次幂模p的值为a。然后有一些不是素数的p对于某些a也有同样的性质,我们就叫他基于a 的Pseudoprime(a从1到p都成立的就叫Carmichael number啦,别的题里大家应该见过)。现在给一些组p和a,判断一下是不是Pseudoprime number。

题目很水,只是借机留下几个基础的模板。详见代码:

#include<iostream>
#include<cstdio>
#include<cmath>

using namespace std;

bool isprime(int n)//试除法判定素数 
{
    int m=floor(sqrt(n)+0.5);
    //这里sqrt应该都懂……+0.5是避免浮点数误差,因为下面枚举时举i<=m的,所以不要紧 
    //如果不用变量m而是直接把sqrt写循环里,那会导致每次都计算一遍sqrt,会增加时间 
    for(int i=2;i<=m;i++)
        if(n%i==0)
            return false;
    return n>1;//最后滤去0和1 
}
int qmul(int a,int b,int mod)//快速乘,类似于快速幂 
{
    int ans=0;
    while(b)
    {
        if(b&1)
            ans=(ans+a)%mod;
        b>>=1;
        a=a*2%mod;
    }
    return ans;
}
int qpow(int a,int n,int mod)//快速幂,自己在纸上随便列两个数写一遍就懂了 
{
    int res=1;
    while(n)
    {
        if(n&1)
            res=qmul(res,a,mod)%mod;//原型为res=res*a%mod,这里没用longlong怕爆 
        n>>=1;
        a=qmul(a,a,mod)%mod;//原型为a=a*a%mod 
    }
    return res;
}
int main()
{
    int p,a;

    while(~scanf("%d%d",&p,&a)&&p|a)
        printf("%s\n",a==qpow(a,p,p)&&!isprime(p)?"yes":"no");

    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自微信公众号。
原始发表:2018-04-06,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 ACM算法日常 微信公众号,前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档