前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 1009 Product of Polynomials (25)

PAT 1009 Product of Polynomials (25)

作者头像
week
发布2018-08-27 09:32:10
2410
发布2018-08-27 09:32:10
举报
文章被收录于专栏:用户画像用户画像

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input

代码语言:javascript
复制
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

代码语言:javascript
复制
3 3 3.6 2 6.0 1 1.6
代码语言:javascript
复制
#include<iostream>
#include<iomanip>
#include<math.h> 
using namespace std;
struct Polynomials 
{
	int exponents;
	double coefficients;
};
int main()
{	
	int i,j,n,m,exponents,cnt=0;
	double coefficients;
	Polynomials a[11],b[11],c[2001];
	cin>>n;
	for(i=0;i<n;i++)
	{
		cin>>a[i].exponents>>a[i].coefficients;
	}
	cin>>m;
	for(i=0;i<m;i++)
	{
		cin>>b[i].exponents>>b[i].coefficients;
	}
	for(i=0;i<=2000;i++)
	{
		c[i].coefficients=0;
		c[i].exponents=i;
	}
	for(i=0;i<n;i++)
	{
		for(j=0;j<m;j++)
		{
			//cout<<a[i].exponents<<" "<<a[i].coefficients<<endl;
			//cout<<b[j].exponents<<" "<<b[j].coefficients<<endl;
			exponents=a[i].exponents+b[j].exponents;//指数相加
			coefficients=a[i].coefficients*b[j].coefficients;//系数相乘
			c[exponents].coefficients+=coefficients;
			//cout<<exponents<<" "<<coefficients<<endl;
		}
	}
	for(i=2000;i>=0;i--)
	{
	
		if(fabs(c[i].coefficients)!=0)
		{
				cnt++;	
		}
	}
	cout<<cnt;
	for(i=2000;i>=0;i--)
	{
		if(fabs(c[i].coefficients)!=0)
		{
			cout<<" "<<c[i].exponents<<" "<<fixed<<setprecision(1)<<c[i].coefficients;
		}
	}
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016年03月07日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档