前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT Pop Sequence

PAT Pop Sequence

作者头像
刘开心_1266679
发布2019-02-14 15:22:39
1K0
发布2019-02-14 15:22:39
举报

02-3. Pop Sequence (25)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

代码语言:javascript
复制
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

代码语言:javascript
复制
YES
NO
NO
YES
NO 

题目大意:        有一个大小为M的栈和一个大小为N的以1为首的升序序列,判断能否利用这个栈将该数组的顺序变成与输入数组相同的顺序,输入的数据有K组。例如:如果M = 5,N = 7,我们可以利用栈得到1,2,3,4,5,6,7,但是不能得到3,2,1,7,5,6,4。如果能得到输入的序列,则输出YES,否则输出NO。 思路:        可以将栈想做中转站,若想使序列从A到B,必须经过有限大的C,如图所示:

如果A[i]和B[j]相等并且C没有满,则判断A的下一位和B的下一位,如果A[i]和B[j]不相等并且C未满,则将A[i]囤积到C,直到C的最上面元素与B[j]相等,取出C的top,如此循环。

代码语言:javascript
复制
#include <cstdio>
#include <stack>
using namespace std;
const int maxn = 1000;


int main()
{
	int m, n, k;
	int arr[maxn];
	scanf("%d%d%d", &m, &n, &k);
	for(int i = 0; i < k; i++)
	{
		int A = 1, B = 0;
		int ok = 1;
		stack<int> s;
		for(int j = 0; j < n; j++)
		{
			scanf("%d", &arr[j]);
		}
		while(B < n)
		{
			if(A == arr[B] && s.size() < m)
			{
				A++;
				B++;	
			}	
			else if(!s.empty() && s.top() == arr[B])
			{
				s.pop();
				B++;	
			} 
			else if(A <= n && s.size() < m)
			{
				s.push(A);
				A++;
			}
			else
			{
				ok = 0;
				break;
			}
		}
		printf("%s\n", ok ? "YES" : "NO");
	}
	return 0;
}</span>
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2015年03月14日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 02-3. Pop Sequence (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档