前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 1086 计算几何 判断线段相交

HDU 1086 计算几何 判断线段相交

作者头像
csxiaoyao
发布2019-02-18 17:55:16
5240
发布2019-02-18 17:55:16
举报
文章被收录于专栏:csxiaoyaocsxiaoyao

题目:

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 6456    Accepted Submission(s): 3116

Problem Description

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :) Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point. Note: You can assume that two segments would not intersect at more than one point. 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending.  A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the number of intersections, and one line one case.

Sample Input

代码语言:javascript
复制

2 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.00 3 0.00 0.00 1.00 1.00 0.00 1.00 1.00 0.000 0.00 0.00 1.00 0.00 0

Sample Output

代码语言:javascript
复制

1 3

代码:

代码语言:javascript
复制
#include<stdio.h>
struct line
{
	float x1,x2,y1,y2,k;
};
bool judge(line l1,line l2)
{
	float b;
	b=((l1.y1+l1.y2)-l1.k*(l1.x1+l1.x2))/2;
	if((l2.x1*l1.k+b-l2.y1)*(l2.x2*l1.k+b-l2.y2)<=0)
		return true;
	else 
		return false;
}
void main()
{
	float x1,y1,x2,y2;
	int n,i,j,count;
	line l[100];
	while(1)
	{
		scanf("%d",&n);
		if(n==0)
			break;
		for(i=0;i<n;i++)
		{
			scanf("%f %f %f %f",&l[i].x1,&l[i].y1,&l[i].x2,&l[i].y2);
			l[i].k=(l[i].y2-l[i].y1)/(l[i].x2-l[i].x1);
		}
		count=0;
		for(i=0;i<n-1;i++)
			for(j=i+1;j<n;j++)
			{
				if(judge(l[i],l[j])&&judge(l[j],l[i]))
					count++;
			}
		printf("%d\n",count);
	}
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014年02月17日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题目:
  • You can Solve a Geometry Problem too
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档