前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 5536--Chip Factory(暴力)

HDU 5536--Chip Factory(暴力)

作者头像
Enterprise_
发布2019-02-20 10:41:02
3750
发布2019-02-20 10:41:02
举报
文章被收录于专栏:小L的魔法馆小L的魔法馆

Chip Factory Time Limit: 18000/9000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 5394 Accepted Submission(s): 2422

Problem Description John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below: maxi,j,k(si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,…,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000 3≤n≤1000 0≤si≤109 There are at most 10 testcases with n>100

Output For each test case, please output an integer indicating the checksum number in a line.

Sample Input 2 3 1 2 3 3 100 200 300

Sample Output 6 400

Source 2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

时间充裕,暴力一发0.0

代码语言:javascript
复制
#include <iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
int a[1005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m=-999;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++){
            for(int j=i+1;j<n;j++){
                for(int k=j+1;k<n;k++){
                    m=max(m,(a[i]+a[j])^a[k]);
                    m=max(m,(a[j]+a[k])^a[i]);
                    m=max(m,(a[i]+a[k])^a[j]);
                }
            }
        }
        printf("%d\n",m);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2018年10月03日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档