前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【Codeforces】1216B - Shooting

【Codeforces】1216B - Shooting

作者头像
喜欢ctrl的cxk
发布2019-11-08 10:34:32
6380
发布2019-11-08 10:34:32
举报
文章被收录于专栏:Don的成长史Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/weixin_42449444/article/details/102454810

Problem Description:

Recently Vasya decided to improve his pistol shooting skills. Today his coach offered him the following exercise. He placed n cans in a row on a table. Cans are numbered from left to right from 1 to n. Vasya has to knock down each can exactly once to finish the exercise. He is allowed to choose the order in which he will knock the cans down.

Vasya knows that the durability of the i-th can is

a_{i}
a_{i}

. It means that if Vasya has already knocked x cans down and is now about to start shooting the i-th one, he will need (

a_{i}
a_{i}

⋅x+1)shots to knock it down. You can assume that if Vasya starts shooting the i-th can, he will be shooting it until he knocks it down.

Your task is to choose such an order of shooting so that the number of shots required to knock each of the n given cans down exactly once is minimum possible.

Input Specification:

The first line of the input contains one integer n (2≤n≤1000) — the number of cans.

The second line of the input contains the sequence

a_{1}
a_{1}

,

a_{2}
a_{2}

,…,

a_{n}
a_{n}

(1≤

a_{i}
a_{i}

≤1000), where aiai is the durability of the i-th can.

Output Specification:

In the first line print the minimum number of shots required to knock each of the n given cans down exactly once.

In the second line print the sequence consisting of n distinct integers from 1 to n — the order of indices of cans that minimizes the number of shots required. If there are several answers, you can print any of them.

Sample Input1:

3 20 10 20

Sample Output1:

43 1 3 2

Sample Input2:

4 10 10 10 10

Sample Output2:

64 2 1 4 3

Sample Input3:

6 5 4 5 4 4 5

Sample Output3:

69 6 1 3 5 2 4

Sample Input4:

2 1 4

Sample Output4:

3

2 1

Note:

In the first example Vasya can start shooting from the first can. He knocks it down with the first shot because he haven't knocked any other cans down before. After that he has to shoot the third can. To knock it down he shoots 20⋅1+1=21 times. After that only second can remains. To knock it down Vasya shoots 10⋅2+1=21 times. So the total number of shots is 1+21+21=43.

In the second example the order of shooting does not matter because all cans have the same durability.

解题思路:

题目大意是:给定n个罐子,第i个罐子a[i]需要射击 (a[i]*x+1) 次,问击倒n个罐子最少需要射击多少次,并输出罐子的初始编号。既然要求最少射击次数,那就用贪心算法吧。我们从需要射击最多次的罐子来开始。我太懒了 不想自定义结构体,然后我就用了一个pair,其中pair的first是击倒罐子所需的射击次数,second是罐子的初始编号,根据first来进行降序排列,然后用sum累加a[i]*x+1进行输出,最后再输出罐子的初始下标second即可。

AC代码:

代码语言:javascript
复制
#include<bits/stdc++.h>
using namespace std;
#define Up(i,a,b) for(int i = a; i <= b; i++)
#define P pair<int,int>  //first是值,second是初始下标
#define mp(x,y) make_pair(x,y)
 
bool cmp(P p1, P p2)
{
	return p1.first > p2.first; 
}
 
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0),cout.tie(0);
	vector<P> v;
	int n;
	cin >> n;
	Up(i,1,n)
	{
		int _;
		cin >> _;
		v.push_back(mp(_,i));
	}
	sort(v.begin(),v.end(),cmp);
	int x = 0,sum = 0,sz = v.size()-1;
	Up(i,0,sz)
	{
		sum += v[i].first*x+1;
		x++;
	}
	cout << sum << endl;
	Up(i,0,sz)
	{
		cout << v[i].second << (i==sz?"\n":" ");
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-10-09 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input1:
  • Sample Output1:
  • Sample Input2:
  • Sample Output2:
  • Sample Input3:
  • Sample Output3:
  • Sample Input4:
  • Sample Output4:
  • Note:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档