前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】 List Sorting

【PAT甲级】 List Sorting

作者头像
喜欢ctrl的cxk
发布2019-11-08 13:50:58
2630
发布2019-11-08 13:50:58
举报
文章被收录于专栏:Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/weixin_42449444/article/details/88828816

Problem Description:

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

代码语言:javascript
复制
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

代码语言:javascript
复制
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

代码语言:javascript
复制
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

代码语言:javascript
复制
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

代码语言:javascript
复制
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

代码语言:javascript
复制
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

解题思路:

这道水题其实并不难,主要就是我这个英语水平读题的时候比较吃力(心中暗暗立下flag:一定要好好恶补英语)。根据C的取值来分情况进行排序,最后无脑for-each进行输出即可。可惜提交代码之后出现了万恶的TLE啊,25分的题只得了21!然后我取消cin和stdin的同步之后还是TLE,那没得一点办法 我只能用printf代替cout进行输出以减少一点点运行时间。诶嘿 提交之后AC啦!

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;

struct stu
{
    string id,name;   //学生的id、姓名
    int grade;   //学生的成绩
};

bool cmp1(stu a,stu b)  //根据id递增排序
{
    return a.id < b.id;
}

bool cmp2(stu a,stu b)  //根据姓名非递减排序,当姓名相同时按照id递增排序
{
    return a.name!=b.name ? a.name<b.name : a.id<b.id;
}

bool cmp3(stu a,stu b)  //根据成绩非递减排序,当成绩相同时按照id递增排序
{
    return a.grade!=b.grade ? a.grade<b.grade : a.id<b.id;
}

int main()
{
    ios::sync_with_stdio(false);    //取消cin和stdin的同步之后还是会TLE
    int N,C;
    cin >> N >> C;
    vector<stu> v;
    for(int i = 0; i < N; i++)
    {
        string id,name;
        int grade;
        cin >> id >> name >> grade;
        v.push_back({id,name,grade});
    }
    switch(C)
    {
        case 1: sort(v.begin(),v.end(),cmp1); break;
        case 2: sort(v.begin(),v.end(),cmp2); break;
        case 3: sort(v.begin(),v.end(),cmp3); break;
        default: break;
    }
    for(auto it : v)
    {
        //cout << it.id << " " << it.name << " " << it.grade << endl;
        //取消cin和stdin的同步之后还是会超时,必须用printf来代替cout进行输出
        printf("%s %s %d\n",it.id.c_str(),it.name.c_str(),it.grade);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/03/26 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input 1:
  • Sample Output 1:
  • Sample Input 2:
  • Sample Output 2:
  • Sample Input 3:
  • Sample Output 3:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档