前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】Sign In and Sign Out

【PAT甲级】Sign In and Sign Out

作者头像
喜欢ctrl的cxk
发布2019-11-08 14:09:39
3660
发布2019-11-08 14:09:39
举报

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/weixin_42449444/article/details/89044369

Problem Description:

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:

3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40

Sample Output:

SC3021234 CS301133

解题思路:

水题。最早登入的人开门,最晚登出的人关门。

AC代码:

#include <bits/stdc++.h>
using namespace std;

int main()
{
    int N;
    cin >> N;
    string start = "99:99:99",end = "00:00:00";   //开门时间start,关门时间end
    string unlock,lock;  //用来记录开门的人和关门的人的id
    while(N--)
    {
        string t1,t2,t3;  //用户名t1,登入时间t2,登出时间t3
        cin >> t1 >> t2 >> t3;
        if(t2 < start)  //最早登入的人开门
        {
            start = t2;
            unlock = t1;
        }
        if(t3 > end)   //最晚登出的人关门
        {
            end = t3;
            lock = t1;
        }
    }
    cout << unlock << " " << lock << endl;
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-04-05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input:
  • Sample Output:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档