前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】Boys vs Girls

【PAT甲级】Boys vs Girls

作者头像
喜欢ctrl的cxk
发布2019-11-08 14:09:58
2680
发布2019-11-08 14:09:58
举报
文章被收录于专栏:Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/weixin_42449444/article/details/89044938

Problem Description:

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F(female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

代码语言:javascript
复制
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

代码语言:javascript
复制
Mary EE990830
Joe Math990112
6

Sample Input 2:

代码语言:javascript
复制
1
Jean M AA980920 60

Sample Output 2:

代码语言:javascript
复制
Absent
Jean AA980920
NA

解题思路:

水题啊。根据性别来将男同学和女同学分别放入俩个vector中,然后将女生降序排列,男生升序排列。如果男生或女生的vector为空,就在相应的行输出"Absent",男生最低分和女生最高分的差值就输出"NA"。否则输出男生最低分和女生最高分的同学姓名、学号,以及俩者的差值。

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;

struct stu
{
    string name;  //学生姓名
    char gender;  //学生性别
    string id;    //学生学号
    int grade;    //学生分数
};

bool fcmp(stu a,stu b)  //女学生降序排列
{
    return a.grade > b.grade;
}

bool mcmp(stu a,stu b)  //男学生升序排列
{
    return a.grade < b.grade;
}

int main()
{
    int N;
    cin >> N;
    vector<stu> male,female;  //男学生、女学生
    while(N--)
    {
        string name,id;
        char gender;
        int grade;
        cin >> name >> gender >> id >> grade;
        if(gender == 'M')  //男性
        {
            male.push_back({name,gender,id,grade});
        }
        else  //女性
        {
            female.push_back({name,gender,id,grade});
        }
    }
    int sum = 0;   //用来记录男女同学的差值
    if(female.empty())   //若没有输入女学生
    {
        cout << "Absent" << endl;
    }
    else
    {
        sort(female.begin(),female.end(),fcmp);
        cout << female[0].name << " " << female[0].id << endl;
        sum += female[0].grade;
    }
    if(male.empty())   //若没有输入男学生
    {
        cout << "Absent" << endl;
    }
    else
    {
        sort(male.begin(),male.end(),mcmp);
        cout << male[0].name << " " << male[0].id << endl;
        sum -= male[0].grade; 
    }
    if(!male.empty() && !female.empty())
    {
        cout << sum << endl;
    }
    else
    {
        cout << "NA" << endl;
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/04/05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input 1:
  • Sample Output 1:
  • Sample Input 2:
  • Sample Output 2:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档