首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】The Dominant Color

【PAT甲级】The Dominant Color

作者头像
喜欢ctrl的cxk
发布2019-11-08 14:19:23
3820
发布2019-11-08 14:19:23
举报

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

本文链接:https://blog.csdn.net/weixin_42449444/article/details/89436173

Problem Description:

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution Mby N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,2​24​​). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

解题思路:

无脑用map记录每个数字出现的次数,maxans记录出现最多的那个数,maxcnt记录出现最多的那个数出现的次数,最后输出maxans即可。

AC代码:

#include <bits/stdc++.h>
using namespace std;

int main()
{
    int M,N;   //N行M列
    cin >> M >> N;
    map<int, int> m;   //map的key是数字,map的cnt是这个数字出现的次数
    int maxans, maxcnt = -1e5;  //出现最多的那个数maxans,出现最多的那个数出现的次数maxcnt
    for(int i = 0; i < N; i++)
    {
        for(int j = 0; j < M; j++)
        {
            int temp;
            cin >> temp;
            m[temp]++;
            if(m[temp] > maxcnt)   //更新出现最多的那个数
            {
                maxcnt = m[temp];
                maxans = temp;
            }
        }
    }
    cout << maxans << endl;
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-04-21 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input:
  • Sample Output:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档