前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】Google Recruitment

【PAT甲级】Google Recruitment

作者头像
喜欢ctrl的cxk
发布2019-11-08 14:22:45
4190
发布2019-11-08 14:22:45
举报
文章被收录于专栏:Don的成长史Don的成长史

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。

代码语言:txt
复制
                 本文链接:[https://blog.csdn.net/weixin\_42449444/article/details/89449874](https://blog.csdn.net/weixin_42449444/article/details/89449874) 

Problem Description:

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

代码语言:javascript
复制
20 5
23654987725541023819

Sample Output 1:

代码语言:javascript
复制
49877

Sample Input 2:

代码语言:javascript
复制
10 3
2468024680

Sample Output 2:

代码语言:javascript
复制
404

解题思路:

这道题在我第一次考乙级的时候遇到过:【PAT乙级】谷歌的招聘。我当时的思路是遍历每个K位string型数字,先用c_str()函数强制转换成char*型,再用atoi()函数强制转换成int型判断它是不是素数。若是素数,把该string型的K位数字赋值给result进行输出,否则输出result的初始化字符串404。后来我才知道原来stoi()可以把string型直接强制转换成int型。

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;
 
bool isPrime(int n)   //判断素数
{
    if(n < 2)
    {
        return false;
    }
    for(int i = 2; i <= sqrt(n); i++)
    {
        if(n%i == 0)
        {
            return false;
        }
    }
    return true;
}
 
int main()
{
    int L,K;
    string N;
    cin >> L >> K >> N;
    string result = "404";
    for (int i = 0; i <= L-K; i++)
    {
        string tempstr = N.substr(i,K);
        int temp = stoi(tempstr);  //string型的数字强制转换成int型的数字
        if(isPrime(temp))  //若这个数字是素数,则用result来记录它
        {
            result = tempstr;
            break;
        }
    }
    cout << result << endl;
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-04-22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description:
  • Input Specification:
  • Output Specification:
  • Sample Input 1:
  • Sample Output 1:
  • Sample Input 2:
  • Sample Output 2:
  • 解题思路:
  • AC代码:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档