专栏首页网络技术联盟站网络工程师入门系列 | 企业网络互联技术

网络工程师入门系列 | 企业网络互联技术

先来简单了解一下计算机网络的基础知识

1.数制的概念及转换

  • 十进制

人们日常生活中最熟悉的进位计数制。在十进制中,数用0,1,2,3,4,5,6,7,8,9这十个符号来描述。计数规则是逢十进一。

  • 二进制

在计算机系统中采用的进位计数制。在二进制中,数用0和1两个符号来描述。计数规则是逢二进一,借一当二。

  • 十六进制

人们在计算机指令代码和数据的书写中经常使用的数制。在十六进制中,数用0,1,…,9和A,B,…,F(或a,b,…,f)16个符号来描述。计数规则是逢十六进一。

2.网线线序

  • 568A标准:白绿,绿,白橙,蓝,白蓝,橙,白棕,棕
  • 568B标准:白橙,橙,白绿,蓝,白蓝,绿,白棕,棕
  • 直通线:两头都用568A线序
  • 交叉线:一头568A一头568B

3.网络七层协议

OSI中的 功能 TCP/IP协议

  • 应用层 文件传输,电子邮件,文件服务,虚拟终端 TFTP,HTTP,SNMP,FTP,SMTP,DNS,RIP,TELNET
  • 表示层 数据格式化,代码转换,数据加密 没有协议
  • 会话层 解除或建立与别的接点的联系 没有协议
  • 传输层 提供端对端的接口 TCP,UDP
  • 网络层 为数据包选择路由 IP,ICMP,OSPF,BGP,IGMP,ARP,RARP
  • 数据链路层 传输有地址的帧以及错误检测功能 SLIP,CSLIP,PPP,MTU,ARP,RARP
  • 物理层 以二进制数据形式在物理媒体上传输数据 IS02110,IEEE802,IEEE802.2

从上到下依次是 七.应用层, 六,表示层, 五,会话层, 四,传输层, 三,网络层, 二,数据链路层, 一,物理层

以一个网络工程师的角度来说,一到四层需要掌握,五六七层面的技术不需要过多的学习,知道原理就行。

4.需要装的软件,华为的 ENSP ,华为官网可以免费下载

5.IP地址及其应用

ip地址的分类

IP地址根据网络号和主机号来分,分为A、B、C三类及特殊地址D、E。全0和全1的都保留不用。

  • A类:(1.0.0.0-126.0.0.0)(默认子网掩码:255.0.0.0或 0xFF000000) 第一个字节为网络号,后三个字节为主机号。该类IP地址的最前面为“0”,所以地址的网络号取值于1~126之间。 一般用于大型网络。
  • B类:(128.1.0.0-191.255.0.0)(默认子网掩码:255.255.0.0或0xFFFF0000) 前两个字节为网络号,后两个字节为主机号。该类IP地址的最前面为“10”,所以地址的网络号取值于128~191之间。 一般用于中等规模网络。
  • C类:(192.0.1.0-223.255.255.0)(子网掩码:255.255.255.0或 0xFFFFFF00) 前三个字节为网络号,最后一个字节为主机号。该类IP地址的最前面为“110”,所以地址的网络号取值于192~223之间。 一般用于小型网络。
  • D类:是多播地址。该类IP地址的最前面为“1110”,所以地址的网络号取值于224~239之间。一般用于多路广播用户。
  • E类:是保留地址。该类IP地址的最前面为“1111”,所以地址的网络号取值于240~255之间。 回送地址:127.0.0.1。也是本机地址,等效于localhost或本机IP。 一般用于测试使用。例如:ping 127.0.0.1来测试本机TCP/IP是否正常。

6.静态路由

路由:源主机到目标主机进行路径选择的过程

路由器:在过程中选择路、找路的设备

路由技术:如何确定一条最佳路径的方法

路由技术原理
  • 下一跳:数据下一次提交的地方
  • 路由是:一个节点到一个节点进行传递

每一个路由器都应该要有去往所有目的网段的路由条目,才能全网互通。

静态路由特点:
  • 手工路由 人为添加
  • 单向
  • 允许精确控制
  • 私有路由
  • 缺乏灵活性
  • 适用于小型网络或者特定网络的路由

第二章 企业网络基础

1.交换机的转发过程

交换机工作于OSI参考模型的第二层,即数据链路层。交换机内部的CPU会在每个端口成功连接时,通过将MAC地址和端口对应,形成一张MAC表。交换机根据MAC地址表转发数据,(可以参考ARP进行理解)

2.路由器的转发过程

路由器是网络层的设备,路由器有很多接口(也就是数据出入的端口),每个接口都有不同网络的IP地址,连接着不同的网络。当一个接口收到一个数据报文后,根据报文头信息,目标地址和原地址,查找路由表,按路由规则,转发到相应的接口上,把数据转发出去。

另外还有ACL,TCP/UDP等转发控制规则,对数据进行是否转发的控制。 当IP子网中的一台主机发送IP分组给同一IP子网的另一台主机时,它将直接把IP分组送到网络上,对方就能收到。而要送给不同IP子网上的主机时,它要选择一个能到达目的子网上的路由器,把IP分组送给该路由器,由路由器负责把IP分组送到目的地。如果没有找到这样的路由器,主机就把IP分组送给一个称为“缺省网关(defaultgateway)”的路由器上。“缺省网关”是每台主机上的一个配置参数,它是接在同一个网络上的某个路由器端口的IP地址。

3. VLAN Trunk VLAN 的作用就是在二层划分广播域, VLAN Trunk可以承载多个VLAN。

如果交换机1的VLAN1中的机器要访问交换机2的VLAN1中的,我们可以把两台交换机的直连端口设置为Trunk端口,这样,当交换机把数据包从级联口发出去的时候,会在数据包中做一个标记(TAG),以使其它交换机识别该数据包属于哪一个VLAN,这样,其它交换机收到这样一个数据包后,只会将该数据包转发到标记中指定的VLAN,从而完成了跨越交换机的VLAN内部数据传输。

第三章

1.实现不同VLAN间通信的方法

我们可以使用单臂路由,三层交换机来解决不同VLAN间的通信。

单臂路由 缺陷太多企业不会选择使用。(理解原理就行)

单臂路由的原理:单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接口(或“逻辑接口”,并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通。

  • 优点:实现不同vlan之间的通信,有助理解、学习VLAN原理和子接口概念。
  • 缺点:容易成为网络单点故障,配置稍有复杂,现实意义不大。

在工作中三层交换机是应用比较广泛的,应该重点学习,

三层交换机 就是具有部分路由器功能的交换机,三层交换机的最重要目的是加快大型局域网内部的数据交换,所具有的路由功能也是为这目的服务的,能够做到一次路由,多次转发。对于数据包转发等规律性的过程由硬件高速实现,而像路由信息更新、路由表维护、路由计算、路由确定等功能,由软件实现。三层交换技术就是二层交换技术+三层转发技术。传统交换技术是在OSI网络标准模型第二层——数据链路层进行操作的,而三层交换技术是在网络模型中的第三层实现了数据包的高速转发,既可实现网络路由功能,又可根据不同网络状况做到最优网络性能。

三层交换机实现VLAN间通信:软件华为ENSP
LSW2上配置 命令
vlan batch 2 to 3 //创建vlan2,vlan3
int e0/0/1 //进入端口e0/0/1
port link-type access //配置access端口

int e0/0/2
port link-type access
port default vlan 2

int e0/0/3
port link-type access
port default vlan 3

int e0/0/4
port link-type trunk //配置trunk端口
port trunk allow-pass vlan 2 to 3

LSW1配置命令 创建vlan 并配置trunk端口
vlan batch 2 to 3

int e0/0/1
port link-type trunk //配置trunk端口
port trunk allow-pass vlan 2 to 3

interface vlanif1 //进入vlan1
ip address 192.168.1.254 255.255.255.0 //配置vlan1ip地址

interface vlanif2
ip address 192.168.2.254 255.255.255.0

interface vlanif3
ip address 192.168.3.254 255.255.255.0

配置完可以ping 命令测试联通性

本文为CSDN博主「习性」的原创文章 原文链接:https://blog.csdn.net/weixin_43751619/article/details/84583246

本文分享自微信公众号 - 网络技术联盟站(it666lmz)

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2019-12-17

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • h5 geolocation 的那些事~

    在讲h5 的geolocation API之前,让我们先了解一下当前国内地理坐标系现状

    IMWeb前端团队
  • Linux 下你所不知道的 7 个 SSH 命令用法

    一个系统管理员可能会同时管理着多台服务器,这些服务器也许会放在不同的地方。要亲自一台一台的去访问来管理它们显然不是最好的方法,通过远程控制的方法应该是最有效的。

    心莱科技雪雁
  • WebRTC学习笔记——建立连接

    WebRTC是一个开源的项目,可以提供浏览器,手机应用之间实时通信能力。 同时,这一功能已经内置于现代浏览器中,所以它可以做到无须借助第三方软件或插件便可以在开...

    IMWeb前端团队
  • Kubernetes 案例分析:从开源第一到企业落地

    企业在 Kubernetes 落地的过程当中都会面临这样那样的问题,今天我把才云 Caicloud 过去在企业落地的过程当中出现的一些问题做个归纳总结,同时也把...

    CNCF
  • Windows系统安全事件日志取证工具:LogonTracer

    最近在做着一些日志分析的活,刚好看到LogonTracer这款工具,于是就参考着网上仅有的文章去搭建了,搭建过程中会多少遇到一些问题,也就顺手将其记录到这篇文章...

    FB客服
  • TCP/IP Cheat Sheet

    实质上,TCP/IP协议族的结构与ISO-OSI的七层协议经典架构稍有不同,通常来讲,我们将之分为四层或者五层。分别是:

    李郑
  • IPv4 地址已耗尽,IPv6 涅槃重生:腾讯云IPv6改造综述

    引言:近日,全球 IPv4 地址正式耗尽的消息刷遍各大技术媒体,IPv6 再一次被推到人们面前。IP,作为网络世界的通行证,其重要性不言而喻。IPv4 地址枯竭...

    尾尾
  • 手动打造Snort+barnyard2+BASE可视化报警平台

    大家在安装基于Snort NIDS系统, 感觉很难,总是出错,其他安装Snort并不难,难的是准备工作做得不充分,如果你做的不好,在配置可视化报警时会遇到各种问...

    OSSIM
  • 解放双手:如何在本地调试远程服务器上的Node代码

    谈到node断点调试,目前主要有三种方式,通过node内置调试工具、通过IDE(如vscode)、通过node-inspector,三者本质上差不多。本文着重点...

    IMWeb前端团队
  • 使用 Python 爬取网页数据

    urllib 是 Python 內建的 HTTP 库, 使用 urllib 可以只需要很简单的步骤就能高效采集数据; 配合 Beautiful 等 HTML 解...

    IMWeb前端团队

扫码关注云+社区

领取腾讯云代金券