专栏首页python3LINUX CENTOS7下安装PYTH

LINUX CENTOS7下安装PYTH

1.查看是否已经安装Python

Centos7默认安装了python2.7.5 因为一些命令要用它比如yum 它使用的是python2.7.5。

使用yum install openssl-devel;安装环境

使用python -V命令查看一下是否安装Python:

然后查看一下Python可执行文件的位置:

进入到bin目录:

可以看到可执行文件python指向python2,python2又指向python2.7也就是说Python命令执行的系统预装的Python2.7。

要安装Python的其他版本先执行mv python python.bak命令备份python文件。

2.安装新版本的Python

下载Python新版本https://www.python.org/downloads/source/

下载tgz包就可以了。其实下面的2个包其一都可以使用 Python-3.5.1.tgz (这个不是编译过的东西,不能解压之后直接使用) Python-3.5.1.tar.xz (这个是pthon的源码)

讲下载的tgz包上传到Linux服务器。

或者执行wget命令直接下载到服务器:wget https://www.python.org/ftp/python/3.5.1/Python-3.5.1.tgz

解压缩:tar -zxvf Python-3.5.1.tgz

加压缩之后该目录下出现Python-3.5.1文件夹,进入到文件夹下执行编译安装。

执行 ./configure –prefix=/usr/local/python/python3 命令。./configure命令执行完毕之后创建一个文件creating Makefile,供下面的make命令使用 执行make install之后就会把程序安装到我们指定的目录中去。

Configure是一个可执行脚本,它有很多选项,在待安装的源码路径下使用命令./configure –help输出详细的选项列表。

其中–prefix选项是配置安装的路径,如果不配置该选项,安装后可执行文件默认放在/usr /local/bin,库文件默认放 在/usr/local/lib,配置文件默认放在/usr/local/etc,其它的资源文件放在/usr /local/share,比较凌乱。

如果配置–prefix,如: ./configure –prefix=/usr/local/test 可以把所有资源文件放在/usr/local/test的路径中,不会杂乱。 用了—prefix选项的另一个好处是卸载软件或移植软件。当某个安装的软件不再需要时,只须简单的删除该安装目录, 就可以把软件卸载得干干净净;移植软件只需拷贝整个目录到另外一个机器即可(相同的操作系统)。

当然要卸载程序,也可以在原来的make目录下用一次make uninstall,但前提是make文件指定过uninstall。

然后执行make、make install命令。

安装成功之后进入到python3文件夹可以看到Python的可执行文件目录、lib目录等相关目录。

执行ln -s /usr/local/python/python3/bin/python3 /usr/bin/python ln -s /usr/local/python/python3/bin/pip3 /usr/bin/pip3 命令创建软连接。 执行python -V查看Python是否安装成功。

安装成功:

3.修改yum配置文件

因为yum使用python2,因此替换为python3后可能无法正常工作,继续使用这个python2.7.5

因此修改yum配置文件(vi /usr/bin/yum)。

把文件头部的#!/usr/bin/python改成#!/usr/bin/python2.7保存退出即可。

因为yum使用python2,因此替换为python3后可能无法正常工作,继续使用这个python2.7.5因此修改yum配置文件(vi /usr/bin/yum)。把文件头部的#!/usr/bin/python改成#!/usr/bin/python2.7保存退出即可

修改/usr/libexec/urlgrabber-ext-down文件,将python同样指向旧版本

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • Python 2.6.6升级到Pytho

    6. 解决升级python后yum无法使用的问题(yum不兼容python2.7)

    py3study
  • Cent OS7安装Python 2.7

        这种安装方式为在系统原基础上进行编译安装python2.7.15不废话,直接开始主题。

    py3study
  • python2.6 升级为 2.7

    CentOS 6.3自带的Python版本为2.6,首先需要升级到2.7版本。由于旧版本的Python已被深度依赖,所以不能卸载原有的Python,只能全新安装...

    py3study
  • Python 2.6.6升级到Pytho

    6. 解决升级python后yum无法使用的问题(yum不兼容python2.7)

    py3study
  • Centos 6.4 python 2.6 升级到 2.7

    Java学习123
  • Cent OS7安装Python 2.7

        这种安装方式为在系统原基础上进行编译安装python2.7.15不废话,直接开始主题。

    py3study
  • python2.6 升级为 2.7

    CentOS 6.3自带的Python版本为2.6,首先需要升级到2.7版本。由于旧版本的Python已被深度依赖,所以不能卸载原有的Python,只能全新安装...

    py3study
  • Python-基础-day2

    Python环境的安装                                                                     ...

    py3study
  • centos系统安装Python

    CentOS 6.5安装Python2.7.14 大家好,周五到了,明天终于可以好好的放松一下了,而且,还是三天的长假哦!自从毕业以后再也没有超过七天的假期了。...

    企鹅号小编
  • 安装 python2.7.10

    在centos6.5 中 默认的Python版本是 2.6.6,我在使用Django最新版本的时候,发现出现语法错误!于是决定升级Python;步骤如下

    py3study

扫码关注云+社区

领取腾讯云代金券