专栏首页python3LAMP(3)安装PHP5、安装PHP7

LAMP(3)安装PHP5、安装PHP7

                                安装PHP5

(目前很多的企业仍然是使用PHP5,因为考虑到兼容的问题)

1.先进入到 /usr/local/src目录(因为我把下载的包都统一放在这里)

cd /usr/local/src

2.下载包: wget http://cn2.php.net/distributions/php-5.6.30.tar.gz

3.解压文件压缩包:

tar -zxvf php-5.6.30.tar.gz

4.安装:

(1)cd php-5.6.30

(2)

./configure --prefix=/usr/local/php --with-apxs2=/usr/local/apache2.4/bin/apxs --with-config-file-path=/usr/local/php/etc  --with-mysql=/usr/local/mysql --with-pdo-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-libxml-dir --with-gd --with-jpeg-dir --with-png-dir --with-freetype-dir --with-iconv-dir --with-zlib-dir --with-bz2 --with-openssl --with-mcrypt --enable-soap --enable-gd-native-ttf --enable-mbstring --enable-sockets --enable-exif

(apxs2:apache的工具,自动的把扩展模块放到apache目录,且自动修改配置文件

)

首次安装PHP,会出现很多次的错误,其实是缺乏一些包:

yum list |grep -i 模糊包名 (一般都是安装:包名+devel)

这里缺乏 openssl (yum install -y openssl-devel)

这里缺乏 bzip2 (yum install -y bzip2-devel)

这里缺乏 libjpeg (yum install -y libjpeg-devel)

这里缺乏 png (yum install -y libpng-devel)

这里缺乏 freetype (yum install -y freetype-devel)

这里缺乏 libmcrypt

libmcrypt 是依赖epel-release这个扩展源的,如果机器没安装先安装 yum install -y epel-release

 再:yum install -y libmcrypt-devel)

安装成功:

5.make 和make install (make && make install)

php安装完后不需启动

安装后:把php的参考配置文件复制到我们定义的php配置文件路径

cp php.ini-production  /usr/local/php/etc/php.ini

(/usr/local/php/etc,这个是在执行.configure时就定义了配置文件路径)

使用命令:/usr/local/php/bin/php -i |less 加-i可以查看到PHP文件的信息

php.ini-production :适应在生产环境中使用(我选用这个)

php.ini-development:适应在开发环境中使用

 )

查看:/usr/local/php/bin/php 加载的模块:(模块都是静态的)

/usr/local/php/bin/php  -m

 (而查看httpd的模块用-M  /usr/local/apache2.4/bin/httpd  -M)?

PHP和Apache结合的核心文件:/usr/local/apache2.4/modules/libphp5.so

modules/libphp5.so 是和加载模块相关的,而PHP就是Apache的一个模块

                         安装php7

1.先进入到 /usr/local/src目录(因为我把下载的包都统一放在这里)

2.下载PHP7包:

wget http://cn2.php.net/distributions/php-7.1.6.tar.bz2

3.解压:

tar -jxvf php-7.1.6.tar.bz2

4.安装:

 cd php-7.1.6

执行 .configure

./configure --prefix=/usr/local/php7 --with-apxs2=/usr/local/apache2.4/bin/apxs --with-config-file-path=/usr/local/php7/etc  --with-pdo-mysql=/usr/local/mysql --with-mysqli=/usr/local/mysql/bin/mysql_config --with-libxml-dir --with-gd --with-jpeg-dir --with-png-dir --with-freetype-dir --with-iconv-dir --with-zlib-dir --with-bz2 --with-openssl --with-mcrypt --enable-soap --enable-gd-native-ttf --enable-mbstring --enable-sockets --enable-exif

5.遍历 make 和 make install

安装完成后:复制配置文件到定义的路径

cp php.ini-production  /usr/local/php7/etc/php.ini

查看apache2.4加载了多少个PHP

 /usr/local/apache2.4/bin/apachectl  -M

根据自己的需求使用哪个版本的PHP(5或7,前提是两个都安装有)?

答:修改配置文件

vim /usr/local/apache2.4/conf/httpd.conf

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • 查看mysqk,php,apache,nginx编译参数

    cat /usr/local/mysql/bin/mysqlbug|grep configure

    py3study
  • 3.安装PHP5和PHP7

    这个路径解压处理虽然不报错,但是没有解压过程,echo查看不报错。==--因为这里没有-v==

    py3study
  • 25. Python 正则(2)

    None       ##从最开头开始匹配,cc不能被正则匹配到,所以返回None

    py3study
  • 安装PHP7

    PHP 7 安装 : 其实安装PHP7的步骤和安装php5完全一样。 下载安装 cd /usr/local/src/ wget http://cn2.php....

    老七Linux
  • 如何搭建LNMP环境【编译版】

    www用户主要是用来赋予nginx和php执行权限,mysql主要是赋予给mysql权限,禁止登录是为了防止用户有权限去操作www和mysql,一切为了安全:

    魔王卷子
  • Prim

    1.dist[n]并不是记录该最小生成树的最小权值 2.两个for(j)循环的意义不一样,第一个是寻找与k点相邻的最小边,第二个是更新与k点相邻的边,当然dis...

    用户1624346
  • 一文了解GaussDB 200的产品架构、数据流程、组网方案、服务部署原则、企业级增强特性...

    墨墨导读:本文是对GaussDB 200产品的整体描述,包含产品架构、数据流程、组网方案、服务部署原则、企业级增强特性等。

    数据和云
  • python代码优化案例分析

    type(0),type(42)等都是同一个对象“<type 'Int'>”,没有必要进行值得比较。因为每一个类型只有一个类型对象。

    py3study
  • C++ 网络编程初学者的开源项目 | 码云周刊第 41 期

    码云项目推荐 互联网的兴起,让网络程序有了长足的发展,让我们可以通过网络编程在程序中实现计算机的通信。举个例子,当你使用浏览器访问码云时,你的计算机就和码云...

    码云Gitee
  • LAMP 平台搭建详解

    LAMP 架构是目前成熟的企业网站应用模式之一,能够提供动态 Web 站点服务及其应用开发环境。 LAMP 是一个缩写词,具体包括: 1、Linux 操作系统 ...

    小手冰凉

扫码关注云+社区

领取腾讯云代金券