前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >05-树8 File Transfer (25分)

05-树8 File Transfer (25分)

作者头像
AI那点小事
发布2020-04-18 20:23:01
4810
发布2020-04-18 20:23:01
举报
文章被收录于专栏:AI那点小事AI那点小事

We have a network of computers and a list of bi-directional connections. Each of these connections allows a file transfer from one computer to another. Is it possible to send a file from any computer on the network to any other?

Input Specification:

Each input file contains one test case. For each test case, the first line contains NN (2\le N\le 10^42≤N≤10 ​4 ​​ ), the total number of computers in a network. Each computer in the network is then represented by a positive integer between 1 and NN. Then in the following lines, the input is given in the format:

I c1 c2 where I stands for inputting a connection between c1 and c2; or

C c1 c2 where C stands for checking if it is possible to transfer files between c1 and c2; or

S where S stands for stopping this case.

Output Specification:

For each C case, print in one line the word “yes” or “no” if it is possible or impossible to transfer files between c1 and c2, respectively. At the end of each case, print in one line “The network is connected.” if there is a path between any pair of computers; or “There are k components.” where k is the number of connected components in this network.

Sample Input 1:

5 C 3 2 I 3 2 C 1 5 I 4 5 I 2 4 C 3 5 S Sample Output 1:

no no yes There are 2 components. Sample Input 2:

5 C 3 2 I 3 2 C 1 5 I 4 5 I 2 4 C 3 5 I 1 3 C 1 5 S Sample Output 2:

no no yes yes The network is connected.


主要思路: 1、用vector存储并查集中的每一个结点 2、合并两个并查集时将结点个数少的并查集并入结点个数多的并查集(若结点个数多的并查集的高度很小,但结点个数少的并查集高度很大,该方法不合适)


AC代码:

代码语言:javascript
复制
#include <iostream>
#include <vector>

using namespace std;

#define Max_Node 10001

typedef struct
{
    int parent;
}Node;

int Find_Set(vector<Node> &set,int value)//寻找当前value所在的并查集的根结点
{
    while (set[value].parent>0)
    {
        value=set[value].parent;
    }
    return value;
}

void Union_Set(vector<Node> &set,int value1,int value2)//合并两个结点的并查集
{
    int root1=Find_Set(set, value1);
    int root2=Find_Set(set, value2);
    if (set[root1].parent<set[root2].parent)//以root1为根的并查集的结点个数更多,将并查集结点个数少的合并到结点个数多的并查集
    {
        set[root2].parent=root1;
        set[root1].parent--;
    }else
    {
        set[root1].parent=root2;
        set[root2].parent--;
    }
}

bool Check_Set(vector<Node> &set,int value1,int value2)//查询两结点是否在同一个并查集
{
    int root1=Find_Set(set, value1);
    int root2=Find_Set(set, value2);
    if (root1==root2)
    {
        return true;
    }else
    {
        return false;
    }
}

int Count_Set(vector<Node> &set)//查询当前并查集的个数
{
    int count=0;
    for (int i=1; i<=set.size(); ++i)
    {
        if (set[i].parent<0)//parent小于0则该结点为一个并查集的根
        {
            count++;
        }
    }
    return count;
}

int main()
{
    int N=0;
    cin>>N;
    vector<Node> Set(N+1);
    for (int i=1; i<=N; ++i)
    {
        Set[i].parent=-1;
    }
    char str;
    int value1=0,value2=0;
    while (1)
    {
        cin>>str;
        if (str=='S')
        {
            break;
        }else if(str=='I')
        {
            cin>>value1>>value2;
            Union_Set(Set, value1, value2);
        }else
        {
            cin>>value1>>value2;
            if (Check_Set(Set, value1, value2))
            {
                cout<<"yes\n";
            }else
            {
                cout<<"no\n";
            }
        }
    }

    int count=Count_Set(Set);
    if (count>1)
    {
        cout<<"There "<<"are "<<count<<" components.";
    }else
    {
        cout<<"The network is connected.";
    }
    return 0;
}

本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档