PHP安装Swoole扩展

什么是Swoole?

Swoole是一种PHP高级Web开发框架,框架不是为了提升网站的性能,是为了提升网站的开发效率。最少的性能损耗,换取最大的开发效率。利用Swoole框架,开发一个复杂的Web功能,可以在很短的时间内完成了。

环境配置

运行环境:Linux Windows Mac FreeBSD Unix

PHP版本支持:PHP5.3+

支持的数据库:MS SQL Server、MySQL、IBM DB2、Oracle、Interbase 、SQLite、PostgreSQL、ODBC

支持的运行方式:Web、Cli命令行脚本、PHP-GTK GUI。

实现功能

1、类似ORM的数据查询,提供SQL封装器,让MySQL的SQL与PHP的Array,会话,Cache无缝结合。

2、App MVC分层结构,有效的程序结构分层,提高程序的可维护性和扩展性,实现低耦合,基于接口开发。

3、集成大量,实用的功能,比如方便的数据库操作,模板操作,缓存操作,系统配置,表单处理,分页,数据调用,字典操作,上传处理,内容编辑,调试等。

4、模板-数据反射系统,可以直接在模板中调用数据,提供很多标签,可是无需修改程序,只修改模板,即可实现网站各类更新维护工作。

5、Swoole包含了大量类,提供众多的功能扩展,基本上Web开发能够用到的功能类,大部分都可以在Swoole框架中找到。

6、Swoole拥有插件系统,Fckeditor、Adodb、pscws中文分词、中文全文索引系统、最新的Key-Value数据库思想,TokyoTyrant,可以无限扩展框架的功能。

安装准备

Swoole下载地址:https://github.com/swoole/swoole-src/releases

php配置文件:phpize php-config(可以使用find命令查找配置文件在什么位置,

find / -name phpize

)。phpize是php安装扩展的一个扩展程序。php-config是配置文件,该文件配置了扩展安装目录等操作,如果我们安装完成之后不知道该扩展安装到那个位置了,可以打开该文件,找到extension该配置项,该配置项的值便是扩展安装目录。

版本要求:php>5.3,gcc>4.0,linux内核>2.3.32

安装步骤

进入swoole安装目录

解压

使用phpize生成配置 /path/phpize

加载配置文件./configure  --with-php-config==/path/php-config

开始编译 make

安装 make install

检测安装是否正常完成 echo $?,如果出现 0则表示正常安装,如果是其他数据则表示安装错误
  1. 进入swoole安装目录
  2. 解压
  3. 使用phpize生成配置 /path/phpize
  4. 加载配置文件./configure --with-php-config==/path/php-config
  5. 开始编译 make
  6. 安装 make install
  7. 检测安装是否正常完成 echo $?,如果出现 0则表示正常安装,如果是其他数据则表示安装错误

添加配置

找到php.ini配置文件,在该文件添加一行

extension=/path/to/swoole.so

重启启动服务,安装即完成。

测试安装结果

创建一个PHP文件,写入如下内容,浏览器访问该文件如果出现图片内容,则表示安装成功。

<?php

      phpinfo();

本文分享自微信公众号 - 卡二条的技术圈(qq1005349393),作者:编程浪子

原文出处及转载信息见文内详细说明,如有侵权,请联系 yunjia_community@tencent.com 删除。

原始发表时间:2017-11-26

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • PHP进程管理器php-fpm配置说明

    php-fpm是PHP的一个进程管理器。php下面的众多work进程皆由php-fpm进程管理器管理。具体可参考:http://www.qqdeveloper....

    卡二条的技术圈子
  • 设计模式第一讲(单例模式)

    大家好,我是卡二条,很感谢大家关注我的个人微信公众号.为什么写这篇文章呢?主要是因为最近在公司负责架构这一块所遇到的一些问题,所感想而来。

    卡二条的技术圈子
  • Nginx与php-fpm之间的通信机制(一)

    讲Fastcgi之前需要先讲CGI,CGI是为了保证web server传递过来的数据是标准格式的,它是一个协议。每种动态语言( PHP,Python 等)的代...

    卡二条的技术圈子
  • phpStudy隐藏后门预警

    近日,phpStudy被公告疑似遭遇黑客攻击,程序包自带PHP的php_xmlrpc.dll模块隐藏有后门,经网友确认phpStudy2016、phpStud...

    洛米唯熊
  • lnmp安装fileinfo模块

    2018-02-0411:44:40 发表评论 38℃热度 fileinfo安装 php.ini 中添加配置 相关服务重启 检查是否成功安装 目录 l...

    timhbw
  • 编译源码安装PHP 5.4

    我们使用vagrant建立虚拟环境,这里使用"chef/centos-6.5"这个box,这个box是一个比较纯净的CentOS-6.5系统。

    用户2131907
  • crontab执行不了php的解决方法 转

    1,在php程序里面写log(例如:error_log()这个函数),这也是必须的,因为crontab定时执行,要是没有log,你怎么知道程序执行的结果怎么样。...

    双面人
  • PHP扩展模块、Apache之rewrite模块

    说明: 在配置文件中加入“extension=redis.so”即可!该文件中“;”表示注释符号,同“#”。

    阿dai学长
  • 基于Mixin Network的PHP比特币开发教程 之一:创建机器人

    Mixin Network 是一个免费的 极速的端对端加密数字货币交易系统. 在本章中,你可以按教程在Mixin Messenger中创建一个bot来接收用户消...

    Mixin Network
  • Linux下php安装

    鉴于Centos 默认yum源的php版本太低了,手动编译安装又有点一些麻烦,那么如何采用Yum安装的方案安装最新版呢。

    用户2929716

扫码关注云+社区

领取腾讯云代金券