伦敦奥运会要到了,小鱼在拼命练习游泳准备参加游泳比赛,可怜的小鱼并不知道鱼类是不能参加人类的奥运会的。 这一天,小鱼给自己的游泳时间做了精确的计时(本题中的计时都按24小时制计算),它发现自己从a时b分一直游泳到当天的c时d分,请你帮小鱼计算一下,它这天一共游了多少时间呢? 小鱼游的好辛苦呀,你可不要算错了哦。 输入输出格式 输入格式: 一行内输入 4 个整数,分别表示 a, b, c, d。 输出格式: 一行内输出 2 个整数 e 和 f,用空格间隔,依次表示小鱼这天一共游了多少小时多少分钟。其中表示分钟的整数 f 应该小于60。 输入输出样例 输入样例#1: 复制 12 50 19 10 输出样例#1: 复制 6 20 说明 对于全部测试数据,0\le a,c \le 240≤a,c≤24,0\le b,d \le 600≤b,d≤60,且结束时间一定晚于开始时间。
C
//一直没想清楚这个第一版为什么会wa:wrong answer On line 1 column 1, read 7, expected 6. 得分0
//#include <stdio.h>
//#include <stdlib.h>
//
//int main()
//{
// int a, b, c, d, e, f;
// scanf("%d %d %d %d", &a, &b, &c, &d);
// e = c - a;
// f = (60 - b) + d;
// if(f > 60){
// f %= 60;
// }
// printf("%d %d", e, f);
// return 0;
//}
#include <stdio.h>
#include <stdlib.h>
int main()
{
int a, b, c, d, e, f;
scanf("%d %d %d %d", &a, &b, &c, &d);
e = c - a;
f = (60 - b) + d;
if(f > 60){
f %= 60;
}
printf("%d %d", e, f);
return 0;
}
C++
#include <iostream>
using namespace std;
int main()
{
int a, b, c, d, temp, e, f;
cin >> a >> b >> c >> d;
temp = (c - a) * 60 + d - b;
e = temp / 60;
f = temp % 60;
cout << e << " " <<f;
return 0;
}
Java
import java.util.Scanner;
/**
* @Auther:bennyrhys@163.com
* @Date:2019/5/8
* @Description:PACKAGE_NAME
* @version:
*/
public class Fish004 {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int a = scanner.nextInt();
int b = scanner.nextInt();
int c = scanner.nextInt();
int d = scanner.nextInt();
int temp = (c - a) * 60 + d - b;
int e = temp / 60;
int f = temp % 60;
System.out.println(e + " " + f);
}
}
Python
#?的游泳时间
a, b, c, d = map(int, input().split())
temp = (c - a) * 60 + d - b
e = int(temp / 60)
f = int(temp % 60)
print(str("{0} {1}").format(e, f))