前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【PAT甲级】1002 A+B for Polynomials (25分)

【PAT甲级】1002 A+B for Polynomials (25分)

作者头像
韩旭051
发布2020-07-21 10:16:32
7990
发布2020-07-21 10:16:32
举报
文章被收录于专栏:刷题笔记刷题笔记

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ a​N​1​​​​ N​2​​ a​N​2​​​​ ... N​K​​ a​N​K​​​​

where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

代码语言:javascript
复制
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

代码语言:javascript
复制
3 2 1.5 1 2.9 0 3.2

三个个坑

一个是 系数为0 不能算进去

一个是 输出格式又要去保留一位小数点Please be accurate to 1 decimal place.

一个是 不能==0 判断 double (其实可以 哈哈)但是 我用 abs(num-0)<0.005 不对 还是精度太小 if( abs(num[i]) >= 1e-15 )

所以要判断一个单精度浮点数:则是if( abs(f) <= 1e-6); 要判断一个双精度浮点数:则是if( abs(f) <= 1e-15 );

自己的答案

代码语言:javascript
复制
#include<iostream>
#include<set>
using namespace std;
double num[10005];
int main(){
	int n;
	set<int>s;
	cin>>n;
	for(int i=0;i<n;i++){
		int a ;
		double b;
		cin>>a>>b;
		num[a]+=b;
	}
	cin>>n;
	for(int i=0;i<n;i++){
		int a ;
		double b;
		cin>>a>>b;
		num[a]+=b;
	}
    int count=0;
    for(int i=0;i<10005;i++){
        if(num[i]!=0){
            count++;
        }
    }
	cout<<count;
	for(int i=10000;i>=0;i--){
		if(num[i]!=0){
            printf(" %d %0.1f", i, num[i]);
			//cout<<" "<<i<<" "<<num[i];
		} 
	}
	return 0;
	
} 

网搜答案

代码语言:javascript
复制
#include<stdio.h>
const int max_n = 1111;
double a[max_n] = {};
int main(){
  
  int k, n, count = 0;
  double e;
  scanf("%d", &k);
  for(int i = 0; i < k; i ++){
    scanf("%d%lf", &n, &e);
    a[n] = e;
  }
  
  scanf("%d", &k);//这里k只是为了存储,所以这儿k是可以重复存放值。
  for(int i = 0; i < k; i ++){
    scanf("%d%lf", &n, &e);
    a[n] += e;//这儿其实就是有相同的就相加,没有相同的就不想加
  }
  
  for(int i = 0; i < max_n; i ++){
    if(a[i] != 0){
      count ++;
    }
  }
  printf("%d", count);
  for(int i = max_n - 1; i >=0; i --){
    if(a[i] != 0) printf(" %d %.1f", i, a[i]);
  }
  return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2020-07-18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Input Specification:
  • Output Specification:
  • Sample Input:
  • Sample Output:
  • 三个个坑
    • 一个是 系数为0 不能算进去
      • 一个是 输出格式又要去保留一位小数点Please be accurate to 1 decimal place.
        • 一个是 不能==0 判断 double (其实可以 哈哈)但是 我用 abs(num-0)<0.005 不对 还是精度太小 if( abs(num[i]) >= 1e-15 )
        领券
        问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档