前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT (Advanced Level) Practice 1039 Course List for Student (25分)

PAT (Advanced Level) Practice 1039 Course List for Student (25分)

作者头像
glm233
发布2020-09-28 11:10:54
4640
发布2020-09-28 11:10:54
举报

1039 Course List for Student (25分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

代码语言:javascript
复制
11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

代码语言:javascript
复制
ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:一看就是经典的题目了,给定n个人m门课,然后给出每门课选的学生名单,最后有k次查询,需要将每个学生的选课数和选的课编号输出

思路:做一map映射,unordered_map<string,set<int>>m,无序map主要为了节省时间,不加应该也能过?没试过,在给出名单的同时将每个学生所选的课存入其名字所对应的值,之所以选择set是因为set自动排序,最后输出即可~

代码语言:javascript
复制
#include<bits/stdc++.h>
#define ll long long
#define rg register ll
#define maxn 100005
using namespace std;
ll n,k,tot;
unordered_map<string,set<ll>>ans;
int main()
{   
    ios::sync_with_stdio(false);
    cin>>n>>k;
    for(rg i=1;i<=k;i++)
    {
        ll a,b;
        cin>>a>>b;
        for(rg i=1;i<=b;i++)
        {
            string q;
            cin>>q;
            ans[q].insert(a);
        }
    }
    for(rg i=1;i<=n;i++)
    {
        string a;
        cin>>a;
        ans[a].size()?cout<<a<<" "<<ans[a].size()<<" ":cout<<a<<" "<<ans[a].size()<<endl;
        ll cnt=0;
        for(auto it:ans[a])
        {
            cnt++;
            cnt==ans[a].size()?cout<<it<<endl:cout<<it<<" ";
        }

    }
    //while(1)getchar();
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-12-17 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Input Specification:
  • Output Specification:
  • Sample Input:
  • Sample Output:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档