首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >第十届山东省赛L题Median(floyd传递闭包)+ poj1975 (昨晚的课程总结错了,什么就出度出度,那应该是叫讨论一个元素与其余的关系)

第十届山东省赛L题Median(floyd传递闭包)+ poj1975 (昨晚的课程总结错了,什么就出度出度,那应该是叫讨论一个元素与其余的关系)

作者头像
风骨散人Chiam
发布2020-10-28 10:32:04
2800
发布2020-10-28 10:32:04
举报
文章被收录于专栏:CSDN旧文CSDN旧文

Median

Time Limit: 1 Second Memory Limit: 65536 KB

Recall the definition of the median of elements where is odd: sort these elements and the median is the -th largest element.

In this problem, the exact value of each element is not given, but relations between some pair of elements are given. The -th relation can be described as , which indicates that the -th element is strictly larger than the -th element.

For all , is it possible to assign values to each element so that all the relations are satisfied and the -th element is the median of the elements?

Input

There are multiple test cases. The first line of the input contains an integer , indicating the number of test cases. For each test case:

The first line contains two integers and (, ), indicating the number of elements and the number of relations. It’s guaranteed that is odd.

For the following lines, the -th line contains two integers and , indicating that the -th element is strictly larger than the -th element. It guaranteed that for all , or .

It’s guaranteed that the sum of of all test cases will not exceed .

Output

For each test case output one line containing one string of length . If it is possible to assign values to each element so that all the relations are satisfied and the -th element is the median, the -th character of the string should be ‘1’, otherwise it should be ‘0’.

Sample Input

2 5 4 1 2 3 2 2 4 2 5 3 2 1 1 2 3 Sample Output

01000 000

Hint

For the first sample test case, as the 2nd element is smaller than the 1st and the 3rd elements and is larger than the 4th and the 5th elements, it’s possible that the 2nd element is the median.

For the second sample test case, as the 1st element can’t be larger than itself, it’s impossible to assign values to the elements so that all the relations are satisfied

#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int dp[105][105],in[105],out[105];
int init()
{
	for(int i=1;i<=105;i++)
	{
		in[i]=0;
		out[i]=0;
		for(int j=1;j<=100;j++)
		{
			dp[i][j]=0;
		}
	}
}
int main()
{
	long long  t;
	cin>>t;
	while(t--)
	{
		init();
		long long n,m;
		cin>>n>>m;
        long long flag=0;
		for(int i=1;i<=m;i++)
		{
			long long  l,r;
			cin>>l>>r;
			dp[l][r]=1;
			if(l==r)    flag=1; //自己排在自己前面是不可能的,直接按题意输出0
		}
		for(int k=1;k<=n;k++)
			for(int i=1;i<=n;i++)
				for(int j=1;j<=n;j++)
					dp[i][j]=(dp[i][k]&&dp[k][j]);//floyd 讨论图的连通性

		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				if(dp[i][j]==1&&dp[j][i]==1)
					flag=1;
        //floyd 讨论图的连通性后,如果出现环的话,就是我排在你前面。你排在我前面,同样不可能
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
				if(dp[i][j]==1)
				{
					in[i]++;    //有几个人排在第I个人前面
					out[j]++;//有几个人排在第j个人后面面
				}
		if(flag)  //不符合现实的按题意输出0
		{
			for(int i=1;i<=n;i++)cout<<"0";
			cout<<endl;
		}
		else
		{
			for(int i=1;i<=n;i++)
			{
				if(in[i]>=(n+1)/2||out[i]>=(n+1)/2)  cout<<"0";
				//如果在他前面或者在他后面的不等于一般的人数,他绝对不是中间位置
				else   cout<<"1";
			}
			cout<<endl;
		}
	}
	return 0;
 }

Median Weight Bead Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 4160 Accepted: 2154 Description

There are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, …, N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads: A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight.

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5.

  1. Bead 2 is heavier than Bead 1.
  2. Bead 4 is heavier than Bead 3.
  3. Bead 5 is heavier than Bead 1.
  4. Bead 4 is heavier than Bead 2.

From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads.

Write a program to count the number of beads which cannot have the median weight. Input

The first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead. Output

There should be one line per test case. Print the number of beads which can never have the medium weight. Sample Input

1 5 4 2 1 4 3 5 1 4 2 Sample Output

2 Source

Tehran Sharif 2004 Preliminary

#include<cstdio>
#include<cstring>
using namespac std;
int a[110][110];
int main()
{
    int T,n,m,i,j,k,d,x,sum;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&n,&m);
        memset(a,0,sizeof(a));
        while(m--){
            scanf("%d%d",&i,&j);
            a[i][j]=1;
        }
        for(k=1;k<=n;k++)
            for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
                    if(a[i][k]&&a[k][j])  //当i比k重,k比j重,则i比j重
                        a[i][j]=1;
        sum=0;
        for(i=1;i<=n;i++){
            d=x=0;
            for(j=1;j<=n;j++){
                if(a[i][j])   跟前面的联通++
                    d++;           
                else if(a[j][i]) 跟后面的联通++
                    x++;
            }
            if(d>=(n+1)/2||x>=(n+1)/2)  如果他是中间位置,他对于前面的连通性应该等于后面,如果不等于且确定的话,他一定不是中间位置。
                sum++;
        }
        printf("%d\n",sum);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-06-13 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档