前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >DP 60题 -2 HDU1025 Constructing Roads In JGShining's Kingdom

DP 60题 -2 HDU1025 Constructing Roads In JGShining's Kingdom

作者头像
风骨散人Chiam
发布2020-10-28 11:08:23
2920
发布2020-10-28 11:08:23
举报
文章被收录于专栏:CSDN旧文

Problem Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. For example, the roads in Figure I are forbidden.

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.

Output

For each test case, output the result in the form of sample. You should tell JGShining what's the maximal number of road(s) can be built.

Sample Input

代码语言:javascript
复制

2 1 2 2 1 3 1 2 2 3 3 1

Sample Output

代码语言:javascript
复制

Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.

Hint

Huge input, scanf is recommended.

Author

JGShining(极光炫影)

Recommend

We have carefully selected several similar problems for you:  1024 1081 1074 1080 1114

这题傻逼,我日了,题意很简单,就是不能交叉的连线最多有多少条,按照第一个排序后,直接LIS,然后我觉得可能超时了,我觉得排序都可以省了,这里有个骚操作,因为他的POOR是连续的,所以可以

代码语言:javascript
复制
scanf("%d%d", &a, &b);
			a[a] = b;

省的排序了,然后想了想,LIS还有O(NlogN)复杂度,所以换了,然后WA了。我日我交了三遍都错了,什么原理呢,我觉得我的思路一点没错,然后看了博客,麻蛋,卡单复数,还卡回车,奶奶的!这谁顶得住!

代码语言:javascript
复制
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<queue>
#include<algorithm>
#include<set>
#include<cmath>
#include<vector>
#include<map>
#include<stack>
#include<bitset>
#include<cstdio>
#include<cstring>
#define Swap(a,b) a^=b^=a^=b
#define cini(n) scanf("%d",&n)
#define cinl(n) scanf("%lld",&n)
#define cinc(n) scanf("%c",&n)
#define cins(s) scanf("%s",s)
#define coui(n) printf("%d",n)
#define couc(n) printf("%c",n)
#define coul(n) printf("%lld",n)
#define speed ios_base::sync_with_stdio(0)
#define Max(a,b) a>b?a:b
#define Min(a,b) a<b?a:b
#define mem(n,x) memset(n,x,sizeof(n))
#define INF  0x3f3f3f3f
#define maxn  100010
#define esp  1e-9
#define mp(a,b) make_pair(a,b)
using namespace std;
typedef long long ll;
//-----------------------*******----------------------------//
int a[1000000];
int dp[1000000];
int main() {
	int n;
	int cse = 1;
	while(scanf("%d", &n) != EOF) {
		int i;
		int a, b;
		int len, pos;
		int val;
		memset(a, 0, sizeof(a));
		for(i = 0; i < n; i++) {
			scanf("%d%d", &a, &b);
			a[a] = b;
		}
		len = 1;
		dp[0] =INF;
		for(i = 1; i <=n; i++) {
			val = a[i];
			if(val > dp[len-1]) {
				dp[len++] = val;
			}
			else {
				pos = upper_bound(dp,dp+len,val)-dp;
				dp[pos] = val;
			}
		}
		printf("Case %d:\n", cse++);
		printf("My king, at most %d %s can be built.\n\n", len, len>1?"roads":"road");
	}
	return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/09/19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档