前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 3164 Command Network

POJ 3164 Command Network

作者头像
风骨散人Chiam
发布2020-10-28 11:26:33
3900
发布2020-10-28 11:26:33
举报
文章被收录于专栏:CSDN旧文

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6 0 6 4 6 0 0 7 20 1 2 1 3 2 3 3 4 3 1 3 2 4 3 0 0 1 0 0 1 1 2 1 3 4 1 2 3 Sample Output

31.19 朱刘算法模板

代码语言:javascript
复制
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <limits.h>
#define maxn 102
#define maxm 10002
#define inf INT_MAX
 
struct Node{
	double x, y;
} ver[maxn];
struct Node2{
	int u, v;
	double cost;
} edge[maxm];
double ans;
int pre[maxn], hash[maxn], vis[maxn];
double in[maxn];
 
bool ZL_MST(int root, int nv, int ne)
{
	ans = 0;
	int i, u, v, cntnode;
	while(true){
		for(i = 0; i < nv; ++i) in[i] = inf;
		for(i = 0; i < ne; ++i){
			u = edge[i].u; v = edge[i].v;
			if(edge[i].cost < in[v] && u != v){
				pre[v] = u; in[v] = edge[i].cost;
			}
		}
		for(i = 0; i < nv; ++i)
			if(i != root && in[i] == inf) return false;
		memset(hash, -1, sizeof(hash));
		memset(vis, -1, sizeof(vis));
		in[root] = cntnode = 0;
		for(i = 0; i < nv; ++i){
			ans += in[i];
			v = i;
			while(vis[v] != i && hash[v] == -1 && v != root){
				vis[v] = i; v = pre[v];
			}
			if(v != root && hash[v] == -1){
				for(u = pre[v]; u != v; u = pre[u]){
					hash[u] = cntnode;
				}
				hash[v] = cntnode++;
			}
		}
		if(cntnode == 0) break;
		for(i = 0; i < nv; ++i)
			if(hash[i] == -1) hash[i] = cntnode++;
 
		for(i = 0; i < ne; ++i){
			v = edge[i].v;
			edge[i].u = hash[edge[i].u];
			edge[i].v = hash[edge[i].v];
			if(edge[i].u != edge[i].v){
				edge[i].cost -= in[v];
			}
		}
 
		nv = cntnode;
		root = hash[root];
	}
	return true;
}
 
int main()
{
	int n, m, a, b, i;
	double x, y;
	while(scanf("%d%d", &n, &m) == 2){
		for(i = 0; i < n; ++i)
			scanf("%lf%lf", &ver[i].x, &ver[i].y);
		for(i = 0; i < m; ++i){
			scanf("%d%d", &a, &b);
			x = ver[--a].x - ver[--b].x;
			y = ver[a].y - ver[b].y;
			edge[i].cost = sqrt(x * x + y * y);
			edge[i].u = a; edge[i].v = b;
		}
		if(ZL_MST(0, n, m)) printf("%.2lf\n", ans);
		else printf("poor snoopy\n");
	}
	return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/10/14 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档