前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 2162 Add ‘em(求和)

HDOJ(HDU) 2162 Add ‘em(求和)

作者头像
谙忆
发布2021-01-21 15:42:32
2220
发布2021-01-21 15:42:32
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description Write a program to determine the summation of several sets of integers.

Input The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.

Output A single line of output should be generated for each set of integers. The line should have format shown below.

Sample Input 4 -1 3 1 1 2 19 17 5 -645 952 -1488 -5456 -9342 -1

Sample Output Sum of #1 is 4 Sum of #2 is 36 Sum of #3 is -15979

简单题,就是求和。

代码语言:javascript
复制
import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t=0;
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==-1){
                break;
            }
            long  sum=0;
            for(int i=0;i<n;i++){
                long a = sc.nextLong();
                sum+=a;
            }
            System.out.println("Sum of #"+(++t)+" is "+sum);
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-05-05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档