专栏首页Tungsten Fabric中文社区TF Analytics指南丨TF中的Underlay Overlay映射(上)
原创

TF Analytics指南丨TF中的Underlay Overlay映射(上)

在上篇文章中,我们概要浏览了TF Analytics的功能,接下来看看如何使用Analytics进行underlay overlay映射。

概述:使用TF Analytics进行underlay overlay映射

注意:本主题适用于Tungsten Fabric 2005版及更早的版本。如果你使用Tungsten Fabric 2008之后的版本,可以《在拓扑视图中查看包路径》一文中查看数据包路径: https://www.juniper.net/documentation/en_US/contrail20/topics/concept/topology-view-packet-path.html

如今的云数据中心由大量相互连接的服务器集合组成,这些服务器为运行各种应用提供计算和存储能力。服务器与冗余的ToR交换机相连,而ToR交换机又与spine路由器相连。云部署通常由多个租户共享,每个租户通常需要多个隔离的网络。多个隔离网络可以通过在underlay网络或物理连接上形成隧道(如gre、ip-in-ip、mac-in-mac)建立的overlay网络来提供。

随着数据在overlay网络中的流动,Tungsten Fabric可以提供underlay网络中流量的统计和可视化。

TF中的Underlay Overlay分析

Tungsten Fabric允许在Web用户界面中查看与underlay和overlay流量相关的各种分析。以下是Tungsten Fabric提供的一些用于统计和可视化overlay underlay流量的分析。

  • 查看underlay网络的拓扑结构。 物理underlay网络的用户界面视图,具有向下钻取机制,以显示连接的服务器(TF计算节点)和服务器上的虚拟机。
  • 查看拓扑结构中任何元素的详细信息。 你可以查看两个元素之间的 pRouter、vRouter或虚拟机链接的详细信息。还可以在所选元素对应的图形视图中查看流量统计。
  • 查看overlay流的underlay路径。 给定一个overlay流,你可以获得该流使用的underlay路径,并在拓扑视图中映射该路径。

架构和数据收集

累积数据以将overlay流映射到其underlay路径,在Tungsten Fabric模块中分几个步骤进行。基本步骤如下:

1.SNMP收集器模块会对物理路由器进行轮询。

SNMP收集器模块利用SNMP协议从TF配置模块接收物理路由器的授权和配置,对所有物理路由器进行轮询。收集器将数据上传至TF分析收集器。SNMP信息存储在pRouter UVEs(物理路由器用户可见实体)中。

2.IPFIX和sFlow协议用于收集流量统计。

物理路由器被配置为使用Internet协议流信息导出(IPFIX)或sFlow(2层数据包导出采样流量的行业标准)作为收集协议向收集器发送流量统计信息。。

3.拓扑模块读取SNMP信息。

TF拓扑模块从分析API中读取pRouter UVE的SNMP信息,计算邻居列表,并将邻居信息写入pRouter UVE中。这个邻居列表被WebUI用来显示物理拓扑。

4.TF用户界面读取并显示拓扑和统计数据。

TF用户界面模块从Tungsten Fabric分析中读取拓扑信息并显示物理拓扑。它还使用分析中存储的信息来显示链路统计的图形,并显示underlay网络上的overlay流映射。

Underlay Overlay映射的新流程/服务

contrail-snmp-collector和contrail-topology是新的daemon进程,它们都被添加到contrail-analytics节点。contrail-analytics包中包含了这些新特性及其相关文件。contrail-status用于显示新服务。

示例:contrail-status

以下是使用contrail-status显示新流程和服务的状态,用于underlay overlay映射的例子。

user@host:~# contrail-status

== Contrail Control ==

supervisor-control:      active

contrail-control       active

…

== Contrail Analytics ==

supervisor-analytics:     active

…

contrail-query-engine     active

contrail-snmp-collector    active

contrail-topology       active

示例:Service命令

Service命令可以用来启动、停止和重新启动新的服务。请看下面的例子。

user@host:~# service contrail-snmp-collector status

contrail-snmp-collector     RUNNING  pid 12179, uptime 1 day, 14:59:11

物理拓扑结构

典型的物理拓扑结构包括:

  • 连接到ToR交换机的服务器。
  • ToR交换机与spine交换机相连。
  • spine交换机与core交换机连接。

以下是WebUI分析中描绘拓扑结构的一个例子。

图1:分析拓扑结构

SNMP配置

在物理设备上配置SNMP,使contrail-snmp-collector能够读取SNMP数据。

以下是瞻博网络设备的SNMP配置示例。

set snmp community public authorization read-only

链路层发现协议(LLDP)配置

在物理设备上配置LLDP,使contrail-snmp-collector能够读取路由器的邻居信息。

以下是瞻博网络设备上LLDP配置的一个例子。

set protocols lldp interface all

set protocols lldp-med interface all

IPFIX和sFlow配置

流量样本由物理设备发送至contrail-collector。由于contrail-collector支持用于接收流量样本的sFlow和IPFIX协议,因此必须将物理设备(如MX系列设备或ToR交换机)配置为使用这些协议之一发送样本。

示例:sFlow配置

以下展示了一个sFlow配置的示例。在该例中,IP变量指的是作为sflow源的设备的环回或可到达的IP,另一个IP变量< collector_IP_data>是收集器设备的地址。

root@host> show configuration protocols sflow | display set

set protocols sflow polling-interval 0

set protocols sflow sample-rate ingress 10

set protocols sflow source-ip 4

set protocols sflow collector   udp-port 6343

set protocols sflow interfaces ge-0/0/0.0

set protocols sflow interfaces ge-0/0/1.0

set protocols sflow interfaces ge-0/0/2.0

set protocols sflow interfaces ge-0/0/3.0

set protocols sflow interfaces ge-0/0/4.0

示例:IPFIX配置

以下为瞻博网络设备的IPFIX配置示例。IP地址变量代表sflow收集器(控制收集器分析节点),代表路由器/交换机设备上用于向收集器发送流量数据的源(出)接口。如果可以从Tungsten Fabric集群到达,该地址也可以是lo0地址。

root@host> show configuration chassis | display set

set chassis tfeb slot 0 sampling-instance sample-ins1

set chassis network-services 



root@host> show configuration chassis tfeb | display set

set chassis tfeb slot 0 sampling-instance sample-ins1



root@host > show configuration services flow-monitoring | display set

set services flow-monitoring version-ipfix template t1 flow-active-timeout 30

set services flow-monitoring version-ipfix template t1 flow-inactive-timeout 30

set services flow-monitoring version-ipfix template t1 template-refresh-rate packets 10

set services flow-monitoring version-ipfix template t1 ipv4-template



root@host > show configuration interfaces | display set | match sampling

set interfaces ge-1/0/0 unit 0 family inet sampling input

set interfaces ge-1/0/1 unit 0 family inet sampling input



root@host> show configuration forwarding-options sampling | display set

set forwarding-options sampling instance sample-ins1 input rate 1

set forwarding-options sampling instance sample-ins1 family inet output flow-server  port 4739

set forwarding-options sampling instance sample-ins1 family inet output flow-server  version-ipfix template t1

set forwarding-options sampling instance sample-ins1 family inet output inline-jflow source-address 

在下一篇文章中,我们将介绍将overlay流映射到其underlay路径的后面两个步骤。


原文链接: https://www.juniper.net/documentation/en_US/contrail20/topics/task/configuration/underlay-overlay-mapping-vnc.html


原创声明,本文系作者授权云+社区发表,未经许可,不得转载。

如有侵权,请联系 yunjia_community@tencent.com 删除。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • TF Analytics指南丨TF中的Underlay Overlay映射(下)

    上篇文章介绍了TF中的underlay overlay分析,以及将overlay流映射到其underlay路径的前两个步骤,接下来继续——

    Tungsten Fabric
  • 杨雨:Tungsten Fabric如何增强Kubernetes的网络性能

    在混合多云的世界里,Kubernetes是如此流行,已经成为应用统一部署和管理的事实标准,而Tungsten Fabric与Kubernetes的集成,更增强了...

    Tungsten Fabric
  • 为OpenStack和K8s集群提供无缝虚拟网络

    现实情况下,可能会发生虚拟机和容器需要相互“交谈”的情况。如果是这样,我们需要以某种方式实现两个独立集群之间的通信。

    Tungsten Fabric
  • TF Analytics指南丨“分析”哪些内容?如何发出“警报”?

    Tungsten Fabric是一个由计算节点、控制节点、配置节点、数据库节点、Web UI节点和分析节点组成的分布式系统。

    Tungsten Fabric
  • TF实战Q&A丨你不理解透,出了问题都不知道怎么弄

    在TF中文社区,爱折腾的“实战派”们经常探讨有关SDN和Tungsten Fabric的各种问题,我们将其中的精华部分整理出来,形成 “ TF Q&A ” 栏目...

    Tungsten Fabric
  • Tungsten Fabric:为云网络而生的SDN控制器

    在当前的IT市场中,组织正将其旧的基础设施迁移到云上,其基础设施的每个部分都在向云化的方向发展。因此,我们有必要来看一下为云级网络(cloud-grade ne...

    Tungsten Fabric
  • Tungsten Fabric如何实现路由的快速收敛?收敛速度有多快?

    在发布R2008版本之前,Tungsten Fabric无法同时提供南北向和东西向流量的快速收敛。

    Tungsten Fabric
  • SDN实战团分享(二十四):Midonet简介

    Midonet是日本的Midokura公司开源出来的Neutron组网方案。Midokura早在2010年就开始做云中的网络虚拟化,他们最开始做Midonet是...

    SDNLAB
  • TF+K8s部署指南丨利用TF防火墙策略实现Kubernetes网络策略(含映射表)

    从5.0版本开始(版本更迭时间和具体内容),Tungsten Fabric支持使用防火墙安全策略框架实现Kubernetes 1.9.2网络策略。虽然Kuber...

    Tungsten Fabric
  • 要在数据中心实现快速收敛?你需要一个快速IP Fabric

    先说一句看起来很“傻”,但在我看来并非琐碎的话:如果一切都按预期进行……那么一切就都会顺利进行。

    Tungsten Fabric
  • SDN实战团分享(三十):解读DC中的overlay与underlay

    企业在上云的时候,一般不会抛弃现有的物理服务器与物理网络设备,而选择完全的虚拟化环境。其原因有如下几点:1. 保护存量投资,进行增量部署;2. 一些特殊类型的工...

    SDNLAB
  • Tungsten Fabric入门宝典丨主流监控系统工具的集成

    (编者按:Prometheus 是一个开源监控系统,几乎所有云原生系统都以 Prometheus的指标格式输出运行时的监控信息。)

    Tungsten Fabric
  • Docker的网络(三)

    从Linux的network namespace开始,通过详细讲解Docker的内置网络host和bridge是怎么使用的,来给大家展示不同容器之间网络的隔离和...

    蒋老湿
  • ORB-SLAM3中的词袋模型BoW

    来源丨https://zhuanlan.zhihu.com/p/354616831

    3D视觉工坊
  • 在K8s上轻松部署Tungsten Fabric的两种方式

    首先介绍下如何在AWS上使用Kubernetes编排的Tungsten Fabric集群部署沙盒,15分钟就可以搞定。Tungsten Fabric集群由部署节...

    Tungsten Fabric
  • Tungsten Fabric解决方案指南-Kubernetes集成(上)

    集成方案中,在Kubernetes和Tungsten Fabric(编者按:原文为Contrail,其开源版已更名为Tungsten Fabric,本文出现Co...

    Tungsten Fabric
  • 让网络更简单:SD-Access 之概览

    作者简介:张磊,思科原厂8年多technical consulting engineer,精通思科数据中心/园区网产品及技术;精通SAN网络架构及产品;熟悉广域...

    SDNLAB
  • SDN那些事:传统网络变身SDN、公有云及NFV 网络专题

    SDN的概念已经提出很多年了,原以为SDN不会立刻在生产环境下部署,但是SDN的商用历程超出了我们的想象。 特别是很多公有云服务商面临业务快速发展的压力,在网络...

    SDNLAB
  • SDN私享汇(十五):SDN之道Juniper Contrail深入解析

    1.介绍 ? 云计算为了适应业务/APP 的快速开发和部署,会把网络分为两层:Overlay和Underlay网络。对于Underlay网络适用于传统的物理网...

    SDNLAB

扫码关注云+社区

领取腾讯云代金券