前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT(甲级)1050.String Subtraction(20)

PAT(甲级)1050.String Subtraction(20)

作者头像
lexingsen
发布2022-02-25 08:04:17
1510
发布2022-02-25 08:04:17
举报
文章被收录于专栏:乐行僧的博客

PAT 1050.String Subtraction(20)

Given two strings S1 and S​2​​ , S=S1−S​2 is defined to be the remaining string after taking all the characters in S​2 from S1. Your task is simply to calculate S1−S2 for any given strings. However, it might not be that simple to do it fast. 输入格式: Each input file contains one test case. Each case consists of two lines which gives S​1​​ and S​2, respectively.The string lengths of both strings are no more than 10^​4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

输出格式: For each test case, print S​1−S2 in one line.

输入样例:

代码语言:javascript
复制
They are students.
aeiou

输出样例:

代码语言:javascript
复制
Thy r stdnts.

题目分析:数组hash的使用,因为题目要求s1-s2,因此开辟一个hash数组用来存放s2中出现的字符,然后遍历s1的所有字符,如果在hash数组中出现过就不输出。

注意:题目给出的字符串可能包含空格,因此不能使用cin进行输入,建议使用getline()进行输入。

AC代码:

代码语言:javascript
复制
#include <iostream>
#include <string>
using namespace std;
const int maxn = 128;
bool is_appear[maxn]={false};

int main(){
    string s1,s2;
    getline(cin, s1);
    getline(cin, s2);
    for(int i=0; i<s2.length(); ++i){
        is_appear[s2[i]] = true;
    }
    for(int i=0; i<s1.length(); ++i){
        if(!is_appear[s1[i]])
            cout<<s1[i];
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档