前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT(甲级)1055.The World's Richest(25)

PAT(甲级)1055.The World's Richest(25)

作者头像
lexingsen
发布2022-02-25 08:04:36
1960
发布2022-02-25 08:04:36
举报
文章被收录于专栏:乐行僧的博客

PAT 1055.The World’s Richest(25) Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

输入格式: Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10^5) - the total number of people, and K (≤10^​3) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10^​6 ,10^​6​​ ]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

输出格式: For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format: Name Age Net_Worth The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

输入样例:

代码语言:javascript
复制
12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

输出样例:

代码语言:javascript
复制
Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题目分析:排序,使用数组存储,使用vector测试点二会超时。

AC代码:

代码语言:javascript
复制
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>

const int maxn = 100010;
using namespace std;
struct people{
    char name[10];
    int age;
    int money;
};

people arr[maxn];

bool cmp(people a, people b){
    if(a.money != b.money)
        return a.money > b.money;
    else if(a.age!=b.age)
        return a.age < b.age;
    else
        return strcmp(a.name, b.name)<0;
}

int main(){
    int n, k;
    scanf("%d%d",&n, &k);
    for(int i=0; i<n; ++i){
        scanf("%s %d %d",arr[i].name, &arr[i].age, &arr[i].money);
    }
    sort(arr,arr+n,cmp);
    int m,Amin,Amax;
    for(int i=0; i<k; ++i){
        printf("Case #%d:\n", i+1);
        scanf("%d%d%d",&m, &Amin, &Amax);
        bool flag = false;
        for(int j=0; j<n && m>0; ++j){
            if(arr[j].age<=Amax && arr[j].age>=Amin){
                printf("%s %d %d\n",arr[j].name, arr[j].age, arr[j].money);
                m --;
                flag = true;
            }
        }
        if(!flag)
            printf("None\n");
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档