前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT(甲级)1105.Spiral Maxtrix(25)

PAT(甲级)1105.Spiral Maxtrix(25)

作者头像
lexingsen
发布2022-02-25 08:05:40
1840
发布2022-02-25 08:05:40
举报
文章被收录于专栏:乐行僧的博客

PAT 1105 Spiral Matrix(25) This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

输入格式: Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10^​4. The numbers in a line are separated by spaces.

输出格式: For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

输入样例:

代码语言:javascript
复制
12
37 76 20 98 76 42 53 95 60 81 58 93

输出样例:

代码语言:javascript
复制
98 95 93
42 37 81
53 20 76
58 60 76

题目分析:模拟题。

AC代码:

代码语言:javascript
复制
#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
using namespace std;

vector<int> v;

int main(void){
    int k, tmp;
    scanf("%d", &k);
    for(int i=0; i<k; ++i){
        scanf("%d", &tmp);
        v.push_back(tmp);
    }
    sort(v.begin(), v.end(), [](int a, int b){return a>b;});
    int n = floor(sqrt(1.0*k));
    while(k % n!=0)n--;
    int m = k / n;

    int arr[m][n];
    bool st[m][n];
    fill(st[0],st[0]+n*m,false);
    fill(arr[0],arr[0]+n*m,0);

    int idx = 0;
    int dx[4] = {-1,0,1,0},dy[4] = {0,1,0,-1};
    int x=0,y=0,d=1;

    for(int i=0; i<n*m; ++i){
        arr[x][y] = v[idx ++];
        st[x][y] = true;
        int a=x+dx[d], b=y+dy[d];

        if(a<0 || a>=m || b<0 || b>=n || st[a][b]){
            d = (d+1)%4;
            a = x+dx[d],b=y+dy[d];
        }
        x=a,y=b;
    }


    for(int i=0; i<m; ++i){
        for(int j=0; j<n; ++j){
            printf("%d",arr[i][j]);
            if(j!=n-1)printf(" ");
        }
        printf("\n");
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档