前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU-1387-Team Queue

HDU-1387-Team Queue

作者头像
全栈程序员站长
发布2022-07-06 09:15:44
3220
发布2022-07-06 09:15:44
举报
文章被收录于专栏:全栈程序员必看

大家好,又见面了,我是全栈君。

Team Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1259 Accepted Submission(s): 430

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 – 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x – enter element x into the team queue DEQUEUE – process the first element and remove it from the queue STOP – end of test case The input will be terminated by a value of 0 for t.

Output

For each test case, first print a line saying “Scenario #k”, where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

代码语言:javascript
复制
    2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

代码语言:javascript
复制
    Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

Source

University of Ulm Local Contest 1998

这几天都在做栈和队列的题。刚刚起步。想多做点!

这个是一个模拟队列的题!

我之前用的链表写的。由于非常久没用链表了。可是这题用链表非常麻烦,确实。纠结我好久,可是还是写出来了,代码不是非常清晰,提交一遍然后TLE了,唉:-(

然后网上看了看别人的代码,发现自己还有非常多不足之处!

!所以说新手还是得多看看别人的代码啊!那个代码思路还是非常清晰的,先贴在这里,以后再来回顾回顾!

我的TLE代码(链表:没用c++里的queue写,一是想练习一下链表。二是想模拟那个过程):

代码语言:javascript
复制
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
using namespace std;

typedef struct que
{
	int da;
	struct que* next;
}*queu, node;

struct fun
{
	int da;
	int te;
}te_me[1000000];

int me_num;

int Len(queu q)
{
	int len=0;
	while(q->next)
	{
		q = q->next;
		len++;
	}
	return len;
}

int query(int a)
{
	for(int i=0; i<me_num; i++)
		if(a == te_me[i].da)return te_me[i].te; 
}

int Entry_q(int a, queu q, int len)
{
	int team = query(a);
	for(int i=0; i < len; i++)
	{
		if(team == query(q->da)  && team != query(q->next->da))
		{
			queu p = (node*)malloc(sizeof(node)); p->next=NULL;
			p->da = a;
			p->next = q->next;
			q->next = p;
			return 1;
		}
		else q = q->next;
	}
	return 0;
}

int main()
{
	int T, count=0;
	while(scanf("%d", &T), T)
	{
		count++;
		int n; me_num=0;
		for(int k = 1; k <= T; k++)
		{
			scanf("%d", &n); int m;
			while(n--)
			{
				scanf("%d", &m);
				te_me[me_num].da = m;
				te_me[me_num].te = k;
				me_num++;
			}
		}
		printf("Scenario #%d\n", count);
		queu q = (node*)malloc(sizeof(node)); q->next=NULL;
		queu front=q, rear=q, p;
		char fun[10]; int elem;
		while(scanf("%s", fun)!=EOF)
		{
			if(!strcmp(fun, "ENQUEUE")){
				scanf("%d", &elem);
				if(front == rear){
					rear->da = elem;
					p = (node*)malloc(sizeof(node)); p->next=NULL;
					rear->next = p; rear = p;
				}
				else if(!Entry_q(elem, front, Len(front))) {
					rear->da = elem;
					p = (node*)malloc(sizeof(node)); p->next=NULL;
					rear->next = p; rear = p; 
				}
			}
			else if(!strcmp(fun, "DEQUEUE")){
				if(front->da)printf("%d\n", front->da);
				queu fe=front;
				front = fe->next;
				free(fe);
			}
			else if(!strcmp(fun, "STOP")){
				break;
			}
		}
		printf("\n");
	}
	return 0;
} 

AC代码(93ms):

代码语言:javascript
复制
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

#define	MAX_RANK 1000000
#define MAX_QUE  1000
#define MAX_N    1000
#define CMD_CHAR 30

int team[MAX_RANK];
queue<int> que[MAX_QUE];
queue<int> bigQue;
void init();
int main()
{
	int cases = 1;

	int teamM;
	while (scanf("%d", &teamM) == 1 && teamM) {
		// init
		init();

		// enter team
		int n;
		memset(team, 0, sizeof(team));
		for (int team_NO = 0; scanf("%d", &n) == 1; team_NO++) {
			for (int i = 0; i < n; i++) {
				int num;
				scanf("%d%*c", &num);
				team[num] = team_NO;
			}
		}

		// read commands
		printf("Scenario #%d\n", cases++);
		while (true) {
			char cmd[CMD_CHAR];
			scanf("%s", cmd);

			if (strcmp(cmd, "ENQUEUE") == 0) {
				int num;	
				scanf("%d%*c", &num);

				if (que[team[num]].empty()) {
					bigQue.push(team[num]);
				}
				que[team[num]].push(num);
			} else if (strcmp(cmd, "DEQUEUE") == 0) {
				int whitch_team = bigQue.front();
				printf("%d\n", que[whitch_team].front());
				que[whitch_team].pop();
				if (que[whitch_team].empty()) {
					bigQue.pop();
				}
			} else {
				printf("\n");
				break;
			}
		}
		
	}

	return 0;
}
void init()
{
	while (!bigQue.empty()) {
		bigQue.pop();
	}

	for (int i = 0; i < MAX_QUE; i++) {
		while (!que[i].empty()) {
			que[i].pop();
		}
	}
}

版权声明:本文博客原创文章,博客,未经同意,不得转载。

发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117438.html原文链接:https://javaforall.cn

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2022年1月5,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Team Queue
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档