前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >2014 (多校)1011 ZCC Loves Codefires

2014 (多校)1011 ZCC Loves Codefires

作者头像
全栈程序员站长
发布2022-07-12 16:51:37
1220
发布2022-07-12 16:51:37
举报

大家好,又见面了,我是全栈君,祝每个程序员都可以多学几门语言。

自从做了多校,整个人都不好了,老是被高中生就算了,题老是都不懂=-=原谅我是个菜鸟,原谅我智力不行。唯一的水题。

Problem Description

代码语言:javascript
复制
       Though ZCC has many Fans, ZCC himself is a crazy Fan of a coder, called "Memset137".
   It was on Codefires(CF), an online competitive programming site, that ZCC knew Memset137, and immediately became his fan.
   But why?
   Because Memset137 can solve all problem in rounds, without unsuccessful submissions; his estimation of time to solve  certain problem is so accurate, that he can surely get an Accepted the second he has predicted. He soon became IGM, the  best title of Codefires. Besides, he is famous for his coding speed and the achievement in the field of Data Structures.
   After become IGM, Memset137 has a new goal: He wants his score in CF rounds to be as large as possible.
   What is score? In Codefires, every problem has 2 attributes, let's call them Ki and Bi(Ki, Bi>0). if Memset137 solves the  problem at Ti-th second, he gained Bi-Ki*Ti score. It's guaranteed Bi-Ki*Ti is always positive during the round time.
   Now that Memset137 can solve every problem, in this problem, Bi is of no concern. Please write a program to calculate the  minimal score he will lose.(that is, the sum of Ki*Ti).

Input

代码语言:javascript
复制
       The first line contains an integer N(1≤N≤10^5), the number of problem in the round.
   The second line contains N integers Ei(1≤Ei≤10^4), the time(second) to solve the i-th problem.
   The last line contains N integers Ki(1≤Ki≤10^4), as was described.

Output

代码语言:javascript
复制
       One integer L, the minimal score he will lose.

Sample Input

代码语言:javascript
复制
    3
10 10 20
1 2 3

Sample Output

代码语言:javascript
复制
    150


    
     
      
      Hint 
     Memset137 takes the first 10 seconds to solve problem B, then solves problem C at the end of the 30th second. Memset137 gets AK at the end of the 40th second. L = 10 * 2 + (10+20) * 3 + (10+20+10) * 1 = 150. 
代码语言:javascript
复制
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e5+10;
struct node{
    int x,y;
}a[maxn];
int cmp(node l1,node l2)
{
    return l1.x*l2.y<l2.x*l1.y;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i].x);
        for(int i=0;i<n;i++)
            scanf("%d",&a[i].y);
        sort(a,a+n,cmp);
        long long sum=0,s=0;
        for(int i=0;i<n;i++)
        {
            sum+=a[i].x;
            s+=sum*a[i].y;
        }
        printf("%I64d\n",s);
    }
    return 0;
}

发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/118721.html原文链接:https://javaforall.cn

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2021年12月,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档