前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >Stack(逆波兰数)

Stack(逆波兰数)

作者头像
废江_小江
发布2022-09-05 13:10:34
3760
发布2022-09-05 13:10:34
举报
文章被收录于专栏:总栏目

Question

Reverse Polish notation is a notation where every operator follows all of its operands. For example, an expression (1+2)*(5+4) in the conventional Polish notation can be represented as 1 2 + 5 4 + * in the Reverse Polish notation. One of advantages of the Reverse Polish notation is that it is parenthesis-free.

Write a program which reads an expression in the Reverse Polish notation and prints the computational result.

An expression in the Reverse Polish notation is calculated using a stack. To evaluate the expression, the program should read symbols in order. If the symbol is an operand, the corresponding value should be pushed into the stack. On the other hand, if the symbols is an operator, the program should pop two elements from the stack, perform the corresponding operations, then push the result in to the stack. The program should repeat this operations.

Input An expression is given in a line. Two consequtive symbols (operand or operator) are separated by a space character.

You can assume that +, – and * are given as the operator and an operand is a positive integer less than 106

Output Print the computational result in a line.

Constraints 2 ≤ the number of operands in the expression ≤ 100 1 ≤ the number of operators in the expression ≤ 99 -1 × 109 ≤ values in the stack ≤ 109 Sample Input 1 1 2 + Sample Output 1 3 Sample Input 2 1 2 + 3 4 – * Sample Output 2 -3 Notes Template in C

Meaning

利用栈实现逆波兰数

Solution

Coding

代码语言:javascript
复制
#include<iostream>
#include<stdlib.h>
#include<cstdio>
#define  max   1005
using namespace std;
int top,S[1000];
void push(int x){
	S[++top]=x;
}
int pop(){
	top--;
	return S[top+1];
}
int main() {
	char c[10]; //这里需要定义一个字符数组,因为读入数字的话就不能为字符,符号可以。
	int a, b,tmp;
	while (scanf("%s",&c)!=EOF){
		if (c[0] == '+') {
			a=pop();
			b=pop();
			push(a+b);
		}
		else if (c[0] == '-') {
			b=pop();
			a=pop();
			push(a-b);
		}
		else if (c[0] == '*') {
			a=pop();
			b=pop();
			push(a*b);
		}
		else {
			push(atoi(c));
		}
	}
	tmp=pop();
	cout << tmp << endl;
}

废江博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 转载请注明原文链接:Stack(逆波兰数)

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2020-04-04),如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Question
  • Meaning
  • Solution
  • Coding
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档