前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >Dictionary

Dictionary

作者头像
废江_小江
发布2022-09-05 14:00:29
4670
发布2022-09-05 14:00:29
举报
文章被收录于专栏:总栏目

Question

Your task is to write a program of a simple dictionary which implements the following instructions:

insert str: insert a string str in to the dictionary

find str: if the distionary contains str, then print ‘yes’, otherwise print ‘no’

Input

In the first line n, the number of instructions is given. In the following n lines, n instructions are given in the above mentioned format.

Output

Print yes or no for each find instruction in a line.

Constraints

A string consists of ‘A’, ‘C’, ‘G’, or ‘T’

1 ≤ length of a string ≤ 12

n ≤ 1000000

Sample Input 1

5

insert A

insert T

insert C

find G

find A

Sample Output 1

no

yes

Sample Input 2

13

insert AAA

insert AAC

insert AGA

insert AGG

insert TTT

find AAA

find CCC

find CCC

insert CCC

find CCC

insert T

find TTT

find T

Sample Output 2

yes

no

no

yes

yes

yes

Meaning

写一个简易字典,输入中给字典插入字符串,然后有查找,如果找到便输出yes,找不到输出no

Solution

没看书本上的解题,第一步想的就是STL里面的vector+find函数,虽然猜到会超时,但先走一遍。

Coding

代码语言:javascript
复制
#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;
vector<string> a;
string tmp;
int main() {
	int n; cin >> n;
	while (n--) {
		cin >> tmp;
		if (tmp[0] == 'i') {
			cin >> tmp;
			a.push_back(tmp);
		}
		else {
			cin >> tmp;
			vector<string>::iterator it;
			it = find(a.begin(), a.end(), tmp);
			if (it != a.end())
				cout << "yes" << endl;
			else
				cout << "no" << endl;
		}
	}
}

Summary

果然没有ac全,只过了九个测试点,这题的话思考一下可以考虑使用散列查找。

废江博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权

转载请注明原文链接:Dictionary

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2020-04-09),如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Question
  • Meaning
  • Solution
  • Coding
  • Summary
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档