描述:
邻近联谊,\text{HF} 最喜欢女装了,为了更好的取悦 \text{LYS} 和观众朋友们(\text{FRI}),\text{LYS} 特地为他准备了四种不同风格的衣服:
在表演时,\text{HF} 会更换不同风格的女装来表演,但每件衣服只能穿一次,\text{LYS} 和 \text{FRI} 的初始 \text{SAN} 值均为 0,若表演过程中:
\text{HF} 想知道,他要如何安排不同风格衣服的表演顺序,才能使自己穿上女装的次数最多?
输入格式:
第一行,一个整数 T, 表示测试样例个数。
每个测试样例输入仅一行,共四个整数 a,b, c, d,分别表示四种不同风格的衣服数量。
输出格式:
输出共 T 行,每行一个整数,表示 \text{HF} 最多能穿上的衣服数量。
数据范围:
1\le T \le 1\times 10^4,
0 \le a,b,c,d \le 1 \times 10^8, 1 \le a + b + c + d。
样例输入:
3
2 0 0 0
1 1 0 2
1 1 1 1
样例输出:
2
3
4
提示:
对于样例 1,\text{HF} 只能选择穿两件女仆风格的衣服,由于已经没有别的衣服可换了,表演结束。
对于样例 2,\text{HF} 先穿女仆风格的衣服,再穿哥特风格的衣服,此时 \text{LYS} 的 \text{SAN} 值为 0,最后再穿一件赛博朋克风格的衣服结束表演。
思想:
代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <sstream>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <unordered_map>
#include <unordered_set>
using namespace std;
#define IOS ios::sync_with_stdio(false),cin.tie(nullptr),cout.tie(nullptr)
#define re register
#define fi first
#define se second
#define endl '\n'
typedef long long LL;
typedef unsigned long long ULL;
typedef pair<int, int> PII;
typedef pair<LL, LL> PLL;
const int N = 1e6 + 3;
const int INF = 0x3f3f3f3f, mod = 1e9 + 7;
const double eps = 1e-6, PI = acos(-1);
void solve(){
LL a, b, c, d; cin >> a >> b >> c >> d;
if(a == 0) cout << 1 << endl;
else cout << a + min(b, c) * 2 + min(a + 1, abs(b - c) + d) << endl;
}
int main(){
IOS;
int _ = 1;
cin >> _;
while(_ --){
solve();
}
return 0;
}