前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >1215: 一道比较水的题

1215: 一道比较水的题

作者头像
怠惰的未禾
发布2023-04-27 21:05:36
1230
发布2023-04-27 21:05:36
举报
文章被收录于专栏:Linux之越战越勇Linux之越战越勇

oj

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if “basketball” is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

Little A是ACM团队的一员。他刚刚在世界决赛中获得金牌。为了庆祝,他决定邀请所有的人吃一顿饭。由于厨房里的碗、刀等餐具不够用,小A去仓库拿备用餐具。仓库里有很多箱子,一个箱子里只装一件东西,每个箱子都标有里面物品的名称。例如,如果盒子上写着“篮球”,这意味着盒子里只有篮球。有了这些标记,小A想要很容易找到餐具。所以,你的问题是帮助他,从仓库的所有盒子里找出所有的餐具。

输入

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

有许多测试用例。每个case包含一行,前面有一个整数N, N表示仓库中有N个箱子。然后是N个字符串,每个字符串是一个写在盒子上的名字。

输出

For each test of the input, output all the name of tableware.

对于每次测试的输入,输出所有餐具的名称。

样例输入 Copy

代码语言:javascript
复制
3 basketball fork chopsticks 
2 bowl letter

样例输出 Copy

代码语言:javascript
复制
fork chopsticks
bowl

提示

The tableware only contains: bowl, knife, fork and chopsticks

餐具只包括:碗、刀、叉和筷子

代码语言:javascript
复制
#include <stdio.h>
#include <string.h>

int main() {
	int n = 0;
	char str[100] = { 0 };
	//记录四种餐具
	char s[4][20] = { "bowl","knife","fork","chopsticks" };
	while (scanf("%d", &n) != EOF) {
		getchar();
		//对每个n,四种餐具如果出现多次则只输出一次
		int flag[4] = { 0 };
		int i = 0;
		for (i = 0; i < n; i++) {
			scanf("%s", str);
			int j = 0;
			for (j = 0; j < 4; j++) {
				if (strcmp(str, s[j]) == 0 && flag[j] == 0) {
					printf("%s ", str);
					flag[j] = 1;
					continue;
				}
			}
		}
		printf("\n");
	}
	return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2022-05-07,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • oj
相关产品与服务
腾讯云服务器利旧
云服务器(Cloud Virtual Machine,CVM)提供安全可靠的弹性计算服务。 您可以实时扩展或缩减计算资源,适应变化的业务需求,并只需按实际使用的资源计费。使用 CVM 可以极大降低您的软硬件采购成本,简化 IT 运维工作。
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档