无法使用anaconda在python中导入faccopg 2怎么办?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (109)

我已经在我的桌面上安装了Anaconda2.7,并希望将它连接到PostgreSQL服务器。

我还通过命令提示符安装了piccopg 2,并取得了成功。但是当我使用Jupyter笔记本导入它时,它会显示以下错误。

ImportError回溯(最近一次调用)在()->1导入C:\Users\amitdarak\AppData\Local\Continuum\anaconda2\lib\site-packages\psycopg2-2.7.3.2-py2.7-win-amd64.egg\psycopg2 2中__依尼特__.py in()48#将DBAPI-2.0组件导入顶级模块。_内核导入(#noqa 51二进制、数字、字符串、日期时间、ROWID、52 ImportError:DLL加载失败:找不到指定模块

提问于
用户回答回答于

conda install -c anaconda postgresql我在Windows 10上运行得很好。

我知道postgresql与psycopg2不是同一个模块,但是postgresql的简单安装将胜过psycopg2对我的任何优势。

扫码关注云+社区

领取腾讯云代金券