如何在apache中启用php7模块?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (237)

当我尝试运行时a2enmod php7.0- 我得到消息“考虑到php7.0的冲突php5”。

重启apache后 - apache无法启动。

怎么解决这个?

也许一些已经启用的模块链接到php5?

参数:Ubuntu Wily,Apache 2.4.18,PHP 7.0.4(仅适用于cli)

提问于
用户回答回答于

首先,禁用该php5模块:

a2dismod php5

然后,启用该php7模块:

a2enmod php7.0

接下来,重新加载/重新启动Apache服务:

service apache2 restart

更新2018-09-04

WRT 的评论,你需要指定精确的安装PHP-7.x的版本。

用户回答回答于

对于寻找相同问题解决方案的Windows用户。我刚才补充道

LoadModule php7_module "C:/xampp/php/php7apache2_4.dll"

在我的 /conf/extra/httpв-xampp.conf

扫码关注云+社区

领取腾讯云代金券