是否有可能在Python 3.6中为iOS编写Kivy应用程序?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (189)

所以我正在使用Kivy开发基于Python的应用程序,并希望将其部署在我的iPhone上进行测试。当我搜索如何做到这一点时,我发现这个网站:https://kivy.org/docs/guide/packaging-ios.html这是在Kivy的官方网站上。

在顶部,它显示'注意目前,iOS的包只能用Python 2.7生成。Python 3.4+支持即将推出。

这个信息是最新的?? 如果是这样,有什么方法可以使用Python 3.6将应用程序部署到我的iPhone上,还是我必须降级到Python 2.7?

编辑:只是想提一下,我在Mac上使用PyCharm。我使用Python 3.6

提问于
用户回答回答于

很不幸的是,不行。IOS目前是唯一没有为python 3做好准备的kivy平台,这是缺乏工具链要求并且可能需要一段时间。目前有一个几乎测试版本用于使用该方法将一些python 3与kivy连接:

kivy.compat.PY2 = False

你可以在这里阅读更多相关信息。但是,我强烈建议你不要使用其中任何一个,因为它比现在的价值更麻烦,特别是如果你想在你的应用程序中有任何稳定性。Python 2.7经过了时间测试,并且在kivy上稳定,所以我建议使用摇摇欲坠的测试版。

如果您已经开始使用python 3,那么您可能需要查看BeeWare。它目前是最新的python 3.6,类似于kivy。

所属标签

可能回答问题的人

  • 嗨喽你好

    7 粉丝480 提问9 回答
  • 富有想象力的人

    3 粉丝0 提问7 回答
  • uncle_light

    5 粉丝518 提问6 回答
  • 人生的旅途

    10 粉丝484 提问6 回答

扫码关注云+社区

领取腾讯云代金券