Xcode 9.2不支持iOS 11.3的Xcode需要9.3?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (346)

显然,随着最新的IOS更新,由于以下错误,我的Xcode版本无法构建。

找不到设备支持文件。此iPhone 7 Plus(型号1661,1784,1785,1786)运行的是iOS 11.3(15E216),此版本的Xcode可能不支持此功能。

试图通过此链接https://developer.apple.com/download/more/安装Xcode 9.3 。但事实证明,我的Mac OS版本将更新视为不兼容的版本。在Sierra 10.12.6上运行

提问于
用户回答回答于

另一种选择是在以下位置下载11.3设备支持:

iOS 11.3(15E217)

并且不要忘记从文件夹名称中删除“(15E217)”,因此它变为“11.3”。之后重启Xcode。

根据EdwardM的评论在哪里粘贴它

对于那些不知道粘贴压缩文件内容的人。在Dock中找到“应用程序”图标,右键单击“打开应用程序”。该文件夹将在Finder中打开。右键单击Xco​​de>显示包内容。然后转到开发人员>平台> iPhoneOS.platform> DeviceSupport

用户回答回答于

扫码关注云+社区

领取腾讯云代金券