如何让“python -m venv”直接安装最新的pip版本

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (175)

作为新python版本的编译步骤的一部分,我获取并运行get-pip.py,以便在python可执行文件旁边安装最新的pip:

$ /opt/python/3.7.0/bin/python --version
Python 3.7.0
$ /opt/python/3.7.0/bin/pip --version
pip 18.0 from /opt/python/3.7.0/lib/python3.7/site-packages/pip (python 3.7)

我有25个这样的版本/opt/python,虽然我主要使用每个major.minor版本不是EOL的五个最新版本。要设置我曾经运行过的invorment,virtualenv或者选择获取具有特定版本的虚拟环境virtualenvutils-p /opt/python/X.Y.Z/bin/python选项。

使用Python 3.7,这给出了imp模块弃用警告:

$ virtualenv -p /opt/python/3.7.0/bin/python /tmp/py37virtualenv
Running virtualenv with interpreter /opt/python/3.7.0/bin/python
Using base prefix '/opt/python/3.7.0'
/opt/util/virtualenvutils/lib/python3.6/site-packages/virtualenv.py:1041: DeprecationWarning: the imp module is deprecated in favour of importlib; see the module's documentation for alternative uses
  import imp
New python executable in /tmp/py37virtualenv/bin/python
Installing setuptools, pip, wheel...done.

我很少希望这将在virtualenv中得到解决,因为PendingDeprecationWarning至少自2014年以来(从这个问题的输出中可以看出)

在调查用in 替换virtualenv时,我首先手动创建了一个新的基于虚拟环境:python -m venvvirtualenvutilsvenv

$ /opt/python/3.7.0/bin/python -m venv /tmp/py37venv
$ /tmp/py37venv/bin/pip --version
pip 10.0.1 from /tmp/py37venv/lib/python3.7/site-packages/pip (python 3.7)

那有一个旧pip版本!如果你使用它,你会得到:

您正在使用pip版本10.0.1,但版本18.0可用。 您应该考虑通过'pip install --upgrade pip'命令进行升级

在随virtualenv您创建的虚拟环境中,立即获取最新版本:

$ /tmp/py37virtualenv/bin/pip --version
pip 18.0 from /tmp/py37virtualenv/lib/python3.7/site-packages/pip (python 3.7)

我可以运行一个创建后的步骤:

/tmp/py37venv/bin/pip install -U --disable-pip-version-check pip 

这需要额外的时间。如果有一些安全更新pip,这意味着运行非安全版本以获得安全版本,一个理想的攻击点。

从中virtualenvutils创建一个pip无用的virtualenv然后添加pip使用的多个步骤是微不足道的get-pip.py。从命令行来看,这不是那么简单:

$ /opt/python/3.7.0/bin/python -m venv --without-pip /tmp/py37venvnopip
$ /tmp/py37venvnopip/bin/python -c "from  urllib.request import urlopen; response = urlopen('https://bootstrap.pypa.io/get-pip'); open('/tmp/tmp_get_pip.py', 'w').write(response.read())"
$ /opt/python/3.7.0/bin/python /tmp/tmp_get_pip.py
......
$ /opt/python/3.7.0/bin/pip --version

来自/opt/python/3.7.0/lib/python3.7/site-packages/pip(python 3.7)的pip 18.0

是什么原因导致/opt/python/3.7.0/bin/python -m venvpip版本?这是3.7.0发布时可用的版本吗?

如何/opt/python/3.7.0以某种方式更新我的安装,以便使用/opt/python/3.7.0/bin/python -m venv最新pip版本创建virtualenv 而无需恢复脚本,别名或使用多个命令?pip安装最新的/opt/python/3.7.0显然是不够的。

有两个捆绑的轮子:

/opt/python/3.7.0/lib/python3.7/ensurepip/_bundled/setuptools-39.0.1-py2.py3-none-any.whl
/opt/python/3.7.0/lib/python3.7/ensurepip/_bundled/pip-10.0.1-py2.py3-none-any.whl

我怀疑我需要更新它们。有没有比手工更新更好的方法?一些选择/some/python -m venv会很好。

(跑步/some/python -m ensurepip --upgrade不行)

运行deprecated /opt/python/3.7.0/bin/pyvenv具有相同的旧pip版本问题。

提问于
用户回答回答于
用户回答回答于

这是一种预期的行为。python -m venv调用python -m ensurepip安装pip此答案显示,ensurepip即使使用--upgrade选项,也只会安装捆绑版本。没有任何官方选项来更新捆绑pipsetuptools

我也没有好主意解决这个问题,因为它只是设计的行为。我想提出两点建议:

  1. 使用pipenv。真的很棒!它将成为未来的下一代官方软件包管理器(虽然目前的Pypi结构存在一个很大的问题。简而言之,软件包管理器只能通过下载整个软件包来决定依赖关系。这给一个很大的难度。构建依赖关系图。)
  2. 实现你的自定义EnvBuilder,实际上有一个官方的例子。在示例中,它还get-pip.py用于安装最新版本pip

扫码关注云+社区

领取腾讯云代金券