Ionic iOS App store上传错误NSPhotoLibraryUsageDescription Key

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (602)

我开发了Ionic 2应用程序。当我尝试将其上传到Apple商店时,他们会拒绝它,并显示以下消息:

缺少Info.plist密钥 - 此应用程序尝试在没有使用说明的情况下访问隐私敏感数据。应用程序的Info.plist必须包含一个NSPhotoLibraryUsageDescription键,其中包含一个字符串值,向用户解释应用程序如何使用此数据。

NSPhotoLibraryUsageDescription在config.xml中添加了密钥

<plugin name="cordova-plugin-camera" spec="https://github.com/apache/cordova-plugin-camera">
                <variable name="CAMERA_USAGE_DESCRIPTION" value="App would like to access the camera." />
                <variable name="PHOTOLIBRARY_USAGE_DESCRIPTION" value="App would like to access the library." />
</plugin>

但他们仍然以同样的信息拒绝了应用程序。我是否需要在所有插件变量中添加此键?我的意思是我也使用了图像选择器插件。我是否还需要在此插件中添加此密钥?我已经添加了,但他们仍然拒绝同样的错误。

提问于
用户回答回答于

在平台ios中插入代码:

<platform name="ios">

<preference name="CAMERA_USAGE_DESCRIPTION" default=" "/>
<config-file target="*-Info.plist" parent="NSCameraUsageDescription">
  <string>$CAMERA_USAGE_DESCRIPTION</string>
</config-file>

热门问答

关于notebook文件导出cos桶报错的疑问?

腾讯智能钛AI开发者

腾讯云 · 智能钛产品团队 (已认证)

腾讯智能钛产品团队官方运营账号。分享产品最新动态,第一时间解答用户疑问。
推荐
这边看您从个人 COS 路径中导入数据到 Notebook ,那么您需要参照以下代码进行鉴权和数据导入。 获取密钥: import os import requests cred_url = os.environ["QCLOUD_CONTAINER_INSTANCE_CREDEN...... 展开详请

iOS实时音视频的SDK和Demo有没有Objective-C版本?

腾讯视频云-ZacharyTXLiteAVSDK技术支持
推荐
下载专业版和企业版的压缩包里面带的官方demo是Objective-C的,下载地址:https://cloud.tencent.com/document/product/647/32689 image.png ... 展开详请

腾讯会议API创建用户UserId 参数设置无效,没有主持人?

推荐
您好!非常感谢您的反馈,您的问题我们已经收到。 api创建的会议,没有主持人权限,请确认请求头中是否有带X-TC-Registered参数。 X-TC-Registered没带是不能获取到主持人身份的。 若解决中还存在其它问题,欢迎继续在社区反馈或【提交工单】,我们收到后会尽快处...... 展开详请

请问小游戏联机对战引擎能在cocoscreater3d中运行吗?

无聊至极互联网重度用户
推荐
您好!非常感谢您的反馈,您的问题我们已经收到,小游戏联机对战引擎能兼容 crearor 3d。 因为 cocoscreator 近期会发布新版本,开发者可以非常便捷的在 crearor2d 的 ide 里面直接开通 mgobe 服务并上传实时服务器代码,所以我们更推荐您使用 cr...... 展开详请

windows(C++)版本的TRTC能不能支持xp?

腾讯视频云-ZacharyTXLiteAVSDK技术支持
推荐
不支持,最低支持WIndows 7,集成文档:https://cloud.tencent.com/document/product/647/32178 image.png ... 展开详请

Android腾讯移动推送快速接入无法运行,tpnsplugin什么时候能修正此问题?

您好,给您造成不便深表歉意,TPNS 团队已经确认此问题,并将在近期排期更新插件以适配新版本 gradle 插件,还请您耐心等待。 目前您可以考虑降级 gradle 插件版本来继续使用 TPNS 快速集成插件,或参考 Android 接入指南:https://cloud.tenc...... 展开详请

所属标签

扫码关注云+社区

领取腾讯云代金券