使用短信API,客户端&服务端TLS版本不一致是否有影响?

  • 回答 (1)
  • 关注 (0)
  • 查看 (13)

我使用腾讯云短信服务用于发送验证码短信,但在使用过程发现以下问题: 1.我在程序中使用openssl1.2版本进行签名&HTTPS通信,但短信发送失败,返回错误码"UnsupportedProtocol"

2.我将以上程序生成的签名串拷贝至fiddler,短信发送成功 经抓包对比发现,fiddler使用的是TLS1.0。因此想询问OpenSSL版本是否会造成该影响?

用户8552734用户8552734提问于
LemonLu

社区 · 运营 (已认证)

Less is more回答于
已采纳

API接口是支持TLS1.0的,需要具体看下调用的报错信息排查

可能回答问题的人

  • 腾讯云DNSPod团队

    77 粉丝0 提问5 回答
  • Jobs

    0 粉丝0 提问2 回答
  • Hcchy

    腾讯云 · 产品经理 (已认证)

    6 粉丝0 提问6 回答
  • 腾讯云通信团队

    腾讯 · 腾讯云通信团队 (已认证)

    66 粉丝0 提问24 回答
  • jansonjiang

    腾讯 · 技术咨询工程师 (已认证)

    16 粉丝0 提问2 回答
  • 龙泉

    2 粉丝1 提问3 回答

扫码关注云+社区

领取腾讯云代金券