如何在Linux中安装Pybluez?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (529)

我试图在我的Linux Mint 15机器上安装PyBluez-0.18,但在安装过程中收到错误消息。

我列出了我尝试执行的命令,以及我收到的错误消息。有人能告诉我我错在哪里吗?

tri108354@prtgc004-Latitude-E6320 ~/Downloads/PyBluez-0.18 $ python setup.py install
running install
running build
running build_py
running build_ext
building 'bluetooth._bluetooth' extension
gcc -pthread -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/home/tri108354/anaconda/include/python2.7 -c bluez/btmodule.c -o build/temp.linux-i686-2.7/bluez/btmodule.o
In file included from bluez/btmodule.c:20:0:
bluez/btmodule.h:5:33: fatal error: bluetooth/bluetooth.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1
提问于
用户回答回答于

你需要安装libbluetooth-dev包来编译你的代码:

sudo apt-get install libbluetooth-dev

扫码关注云+社区

领取腾讯云代金券