在浏览器中支持不同的Javascript版本

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (28)

这里浏览MDC文档,我注意到有相当多的JavaScript版本(1.6到1.8.5)。

我在想:

  1. 是否支持浏览器/ Javascript版本的在线参考?
  2. 是否有任何实际的应用程序使用不同的JavaScript版本?根据MDC你需要做这样的事情来使用它们:

<script type="application/javascript;version=1.7"/>

提问于
用户回答回答于

1)列表:http : //en.wikipedia.org/wiki/JavaScript#Version_history

2)对于网站来说,使用更新版本的Javascript并不是一个好主意,但对于新版浏览器的插件可能会有所帮助。例如,我forEach在Google Chrome的插件中使用该功能

用户回答回答于
  1. 有一个相当不错的浏览器/版本图表,请在这里查看
    • 注意:JavaScript不是唯一的ECMAScript实现,而JavaScript(由Mozilla维护的标准)和JavaScript语言(更一般,有时不准确使用的术语)并不是一回事,例如IE的实现叫做JScript
  2. 不是我从来没有见过任何实用/广泛的事情......你必须做一些非常具体/专门的事情,才能有任何优点。

扫码关注云+社区